URGENT HELP NEEDED: USPS Live Shipping rate testing

Posted: November 19, 2009 at 1:39 PM Quote #6963
I have my nopCommerce store set up on LOCALHOST with few products and now want to test the shipping rates before going live. In the "Edit shipping rate computation method" I have changed the URL as per the following email that I got from USPS after I created an account with them for their webtools: "Depending on the API, the address to the test server is either http://testing.shippingapis.com/ShippingAPITest.dll or https://secure.shippingapis.com/ShippingAPITest.dll"
I have tried either of the URLs and none seem to work. This is the error that the page gives at the top when I try to do checkout for any product, to see if I am getting the shipping rates as per expected: "USPS Error returned: Error Desc: API Authorization failure. RateV3 is not a valid API name for this protocol."

I am really stuck here and need to get this thing tested ASAP so that I can, thereafter, go live with the deployment of the store.

Thank you for your time and the anticipated solution.

-NJ-
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: November 20, 2009 at 1:13 PM Quote #6994
Success! Thanks for looking.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: November 24, 2009 at 1:14 PM Quote #7161
Hi

Could you tell me what you did on order to pass this error message? I am getting the same one, and I am afraid I am out of my depth here, absolutely.

Thank you,
-Irina
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: November 24, 2009 at 1:36 PM Quote #7162
Hi Irina,

I assume you are trying to test the shipping rates through the URL sent by USPS in the email and using the username/password they provided. Here is the concept: the URL they send us is to test those systems which are being developed from scratch to incorporate the USPS API and then test if the integration is working as expected and are we getting the live rates. This URL, that they send us, is for the Test Server. Since we are just trying to do development on top of a third-party system, this functionality has already been implemented into the system and we dont really need to worry about the URL they send us (although using that URL and some specific values of 'origin zipcode' and 'destination zipcode' you can still test it).

Solution: Call USPS on the number they sent you in the email and ask them to transfer your account to the Production Server from the Test Server. They should do it instantly and send you a confirmation email. Thats is, you are good to go! Test it again now.. Good Luck.

-NJ-
This post/answer is useful
1
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: November 24, 2009 at 3:42 PM Quote #7169
Thanks a lot!

It worked this time. I called them before, but I guess I just didn't know the right words then, because they refused to do this :o)

-Irina
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: November 09, 2010 at 12:01 PM Quote #29464
What email are you referring to? I have had UPS and USPS accounts for years and have no idea what sign-up email I may have received. Any help is appreciated.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
nopCommerce on facebook