Input error: k: Format of site key was invalid Captcha Problem

Posted: 2 years ago Quote #67319
Can't get to admin panel because of this error. Tried the website/administrator thing and it didn't work either.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 2 years ago Quote #67327
You've got an invalid key. The only way to fix this is to go out to the SQL database, open up the Settings Table, and set the value of record # 341 to False.

Once that's done, follow the instructions and log into the reCaptcha site on Goggle and get your public and private keys from them. Copy and paste into the spaces on your admin form, save, then restart the Captcha process.
This post/answer is useful
1
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Mike Aurelius
President
(which means in a small 1-man company, I do *everything*)
Posted: 2 years ago Quote #67333
Thank you for the fast reply!
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 2 years ago Quote #67339
mikeaurelius wrote:
set the value of record # 341 to False

Identifiers could be different. I would better find this setting by name 'captchasettings.enabled'
This post/answer is useful
2
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Interested in the dedicated Premium support services provided by core developers? Please visit http://www.nopcommerce.com/supportservices.aspx

Best Regards,
Andrei Mazoulnitsyn
Posted: 2 years ago Quote #67418
That's a trap for new players! I knew exactly what I had done when I was no longer able to login!

Cheers,

Guys.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: one year ago Quote #75267
mikeaurelius wrote:
set the value of record # 341 to False

Identifiers could be different. I would better find this setting by name 'captchasettings.enabled'

Sorry, still a newbie.  Using 2.5. Where would we find catchasetting.enabled from File Management system? We are locked out of our Administration after enabling Captcha in the Admin for the website. Getting the same error as above.

Thanks from the bayou country of South Louisiana, USA!
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: one year ago Quote #75271
Think I found the solution here:

http://www.nopcommerce.com/boards/t/16194/loginnew-registration-errors.aspx
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 7 months ago Quote #105651
Go to SQL Server Management Studio and Run Following Query.

It will list setting having name Captcha in name column.

select * from Setting where name like '%captcha%'


Find record having name 'captchasettings.enabled'

Here for NopCommerce 3.10 version it is having ID 409.

Then run update query to set value to false.

update Setting set Value='False' where Id='409' and Name='captchasettings.enabled'

Captcha setting is disabled now.

Now Open command prompt.
Go to run, Type cmd, Press Enter.

Run - IISRESET command to restart IIS server.

Now, check nopcommerce site. It will allow you to login without inserting captcha.
This post/answer is useful
1
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
nopCommerce on facebook