How to setup USPS and UPS shipping

Posted: 4 years ago Quote #6170
Good Day,

I am using nopCommerce 1.3 for the first time and I would like to setup the automatic USPS and UPS shipping.  However it looks like I need to setup some API access usernames and passwords for these.  Can anyone tell me how I might do this, where I need to go, etc?  There doesn't seem to be any documentation on it.

Thanks!
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #6176
I think I found what I needed on USPS, however now NOP is giving me the following error:

USPS Error returned: Error Desc: API Authorization failure. RateV3 is not a valid API name for this protocol.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #6602
I am getting the exact same error.  I am using the following URL per the usps site for testing. http://testing.shippingapis.com/ShippingAPITest.dll
They gave me a test id and pw.

USPS Error returned: Error Desc: API Authorization failure. RateV3 is not a valid API name for this protocol.
Before this i was getting a general error page and after reading thru the log it was returning a "Shipping Error: Package too large" error.  After reducing my test products weight from 22 lbs to 5 i started getting the error above.  I will continue to read the usps site.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #6616
RateV2 will still work with the test server -- however, the structure of the xml request is different since it doesn't allow for length, width or height.

RateV3 will only works on the production server http://production.shippingapis.com/ShippingAPI.dll, not the test server. The test server is only for direct calls using static xml and no details.  Some test environment.  Anyway after changing to the production server I got : Error Desc: Authorization failure. You are not authorized to connect to this server. "  So at least i feel like i am making some headway.  Next i am calling usps to find out why my company login isn't working in production.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #6626
Buzworks,

It's because you have to send 1 test call through on the test server successfully before they will allow your site to call the production call.  I'm working on this part today hopefully.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #6919
Are there any updates to this.  I am getting the same message.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #6932
Just simply call the number provided in your USPS sign up email, and they will switch you to live mode automatically and give you the proper URL to use for nopCommerce.  Took me maybe 5 min once I called.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #8551
I am still lost.  I have done the following:

I have registerd and got the url,username and password.

I have log on as admin and inputted this on the shipping rate computation methond screen.

and I get the error:
USPS Error returned: Error Desc: API Authorization failure. RateV3 is not a valid API name for this protocol.

Do I have to do anything else to test this.

Above they say this will only work on the production server.  How do I test and why would
they send me a testing url (http://testing.shippingapis.com/ShippingAPITest.dll) if it should be ran in production.

Was I supposed to contact ICCC.

I am lost.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #8553
Hi I found my solution I think.  I will have to try it tomorrow.

The solution was found here.

http://www.nopcommerce.com/Boards/Topic.aspx?TopicID=1958

and I include the text here

Hi Irina,

I assume you are trying to test the shipping rates through the URL sent by USPS in the email and using the username/password they provided. Here is the concept: the URL they send us is to test those systems which are being developed from scratch to incorporate the USPS API and then test if the integration is working as expected and are we getting the live rates. This URL, that they send us, is for the Test Server. Since we are just trying to do development on top of a third-party system, this functionality has already been implemented into the system and we dont really need to worry about the URL they send us (although using that URL and some specific values of 'origin zipcode' and 'destination zipcode' you can still test it).

Solution: Call USPS on the number they sent you in the email and ask them to transfer your account to the Production Server from the Test Server. They should do it instantly and send you a confirmation email. Thats is, you are good to go! Test it again now.. Good Luck.

-NJ-

Thanks

Howard
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: 4 years ago Quote #8557
It worked.  The information here has been great
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
nopCommerce on facebook