The 5th annual nopCommerce conference will take place in India on the 10th-11th of October. Please find more about this event here

Upgrade 1.2 to 1.30 on Go Daddy

1 2 >
Posted: September 13, 2009 at 8:55 PM Quote #4780
I used the automated installer for nopCommerce 1.2 that's provided by Go Daddy in the Hosting Connection.  The installation worked find and the application works great.  I'd like to upgrade to 1.3.  I could use some help.  It seems that I need to manually download 1.3, upload the file and unzip it via the Go Daddy file manager.   I see there's an SQL upgrade script too.  Has anyone been successful with this upgrade on a Go Daddy account? If so, can you provide some instructions, such as the order to accomplish the tasks.  Other than uploading and unzipping, should an installer be run?  Which download should be used: the one that just says "no source" or the one that says "Web Deploy"?  If "Web Deploy" then I assume there's an installer or upgrade routine to run?
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: September 14, 2009 at 6:09 AM Quote #4790
Hi,

First take a copy of the connectionstrings.config file. As the web install does not like Godaddy databases.

You should download the non source version of nopcommerce 1.30

Then upload all the 1.30 files overwriting the 1.20 files. Once you have done that upload the connectionstrings.config file you created earlier so it replaces the 1.30 version.

Next

Go into your Hosting Control Panel, Select Databases then SQL Server.

Click Manage Via web admin on your nopcommerce SQL server & Login using your database username and password.

4a. Expand the tools folder on the left (if it is not already) and click on Query Analyzer.

4b. Now Press Open SQL File. Navigate to the Install/Scripts/1.30 File within Nop Commerce on your local machine and open nopCommerce_upgrade.sql once this has opened press Execute. This will have updated your database for you.

Now visit your site it should be working fine and be upgraded to version 1.30.

Hope that helps.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: September 14, 2009 at 1:53 PM Quote #4798
Thanks!  That helped tremendously.  I was successful in getting everything upgraded.  It took me a minute to realize that I'd be browsing my own hard drive for the SQL script to run, rather than the files/folders I had just uploaded, but then it went smoothly.  I now have 1.30 up and running.
Thanks again!
Jarrett
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: September 15, 2009 at 6:33 AM Quote #4813
No Problem! Glad I could be of help.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: September 26, 2009 at 9:28 PM Quote #5150
Tried it but it still puts me back to the install menu


rather than to my website
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: October 09, 2009 at 1:41 AM Quote #5491
Leesh,
Thanks for the precise instructions. I think I was able to upgrade my installation. But the version on the admin header still says 1.2. I did check the release notes and i understand 1.3 has IP blacklists as new. I do have IP blacklist on the admin menu. how else can i confirm the version?
Thanks,
Z
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: October 09, 2009 at 8:41 AM Quote #5505
You version setting was not update if you run nopCommerce_upgrade.sql file. The version setting is updated by the installer (ASPX). So if you have Blacklist menu in admin area, then you have 1.30
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Interested in the dedicated Premium support services provided by core developers? Please visit http://www.nopcommerce.com/supportservices.aspx

Regards,
Andrei Mazulnitsyn
Posted: October 09, 2009 at 10:42 AM Quote #5512
Thanks for that too. Boy, this place rocks!
Z
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: October 13, 2009 at 3:38 PM Quote #5649
You version setting was not update if you run nopCommerce_upgrade.sql file. The version setting is updated by the installer (ASPX). So if you have Blacklist menu in admin area, then you have 1.30

So what would be the correct method for updating to 1.30 on a GoDaddy installed 1.20 nopcommerce site?
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: October 13, 2009 at 4:23 PM Quote #5650
Do a search on this forum using upgrade, update or GoDaddy
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
1 2 >
Premium support services
  • Dedicated premium support services provided by core developers are intended for persons who run mission critical websites, work on projects with tight deadlines, or want to get dedicated support.
Professional services
  • Want to open a new store? Want to take your store to the next level? Need a custom extension? We can customize nopCommerce to fit your store perfectly. Request a quote to get started.
eCommerce CONFERENCE 2019
Learn more