Getting started. Installing and upgrading nopCommerce.

1 2 3 >
Posted: January 18, 2012 at 12:30 AM Quote #60064
Before posting the questions, please read the following articles. They describe how to download nopCommerce software, upload it to your server, define the file permissions, and install it on your system. You'll also get information on how to upgrade nopCommerce to the latest version.

Technology & System Requirements
Installing nopCommerce
Upgrading nopCommerce
This post/answer is useful
2
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Interested in the dedicated Premium support services provided by core developers? Please visit http://www.nopcommerce.com/supportservices.aspx

Regards,
Andrei Mazulnitsyn
Posted: July 11, 2012 at 3:27 AM Quote #73746
Hello,

I would like to upgrade from 1.9 to 2.6, but I don't see the previous versions on the downloads page, which is where I think they use to be.  Please help me locate these as I'm preparing to coordinate.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: July 11, 2012 at 3:37 AM Quote #73747
herzow wrote:
Hello,

I would like to upgrade from 1.9 to 2.6, but I don't see the previous versions on the downloads page, which is where I think they use to be.  Please help me locate these as I'm preparing to coordinate.



Please download it from here
http://nopcommerce.codeplex.com/releases/view/85441

You will get all versions here.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Please VOTE for the post if it meets your expectation. We are here to help...

Thanks
Top-Nop (www.top-nop.com)

sales:- [email protected]
Posted: July 11, 2012 at 3:51 AM Quote #73749
I found them here... http://nopcommerce.codeplex.com/SourceControl/changeset/view/580423cd02a4

Wonder why they were moved.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: October 26, 2012 at 12:34 PM Quote #81765
My new company runs an nop site on the recommendation of our incumbent web agency.

It's running on 1.9 & went live in March this year. Generally we are pleased with the results but I was hoping for some advice from the nop forums.

Firstly 1.9 was released in Dec 2010, why would our agency not build on a later version eg 2.3 or 2.4? License rationale?

Secondly I would like to upgrade to the latest version particularly for the mobile version, however I'm being told that there are too many bespoke alterations to our site to make the upgrade an economical option. Any comments on this please?

Any thoughts or advice would be greatly appreciated.

The site is generating good revenues for us & customer feedback has been good. However I can see future versions being central to the businesses success, particularly through integration into Sage?, courier dispatch, stock management etc
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: October 26, 2012 at 6:04 PM Quote #81788
Magic eSales wrote:
My new company runs an nop site on the recommendation of our incumbent web agency.

It's running on 1.9 & went live in March this year. Generally we are pleased with the results but I was hoping for some advice from the nop forums.

1) Firstly 1.9 was released in Dec 2010, why would our agency not build on a later version eg 2.3 or 2.4? License rationale?

2) Secondly I would like to upgrade to the latest version particularly for the mobile version, however I'm being told that there are too many bespoke alterations to our site to make the upgrade an economical option. Any comments on this please?

Any thoughts or advice would be greatly appreciated.

The site is generating good revenues for us & customer feedback has been good. However I can see future versions being central to the businesses success, particularly through integration into Sage?, courier dispatch, stock management etc


1)There was a total change of technology from 1.9 to 2.0 (which first came out in august/11) using MVC. Maybe your agency didn't want to take risks of starting with an insufficiently tested version or maybe they were not familiar with MVC technology.

2) To upgrade first from 1.9 to 2.0 and then step-wise to present version (2.65) may be quite a challenge mainly if, as you said, there was a lot of customization work in the original version.
This post/answer is useful
1
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Regards

Eduardo

www.tecnofin.com
nopCommerce Solution Partner
-----------------------------------------------------------
Developer of e-Commerce sites since 1996
Mexico - USA - Canada - Chile - Colombia - Costa Rica - Peru
Desarrollo de sitios de comercio electrónico
Posted: June 24, 2013 at 3:34 AM Quote #99594
I've asked this before without sucess so will try again, We have this site installed and it works flawlessly on all computers except a new acer laptop running windows 7 home premium version 6.1, its completley standard.
The website is visible but no stock or clients can be seen, ironically I can see all transactions, What would prevent this site from working on this laptop, Thankyou.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: June 28, 2013 at 12:27 AM Quote #99983
I followed the instruction after upgrade from 1.6 to 1.7
I can browse website but writing is all over the place specially into chrome browser
I cannot find settings.txt and InstalledPlugins.txt files into App_Data directory into 1.6 version to move into version 1.7
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: November 19, 2013 at 8:26 PM Quote #109415
I want to upgrade from nopCommerce 1.4 to the latest 3.10. Can i get some advise on the best path to do this.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: December 12, 2013 at 1:19 PM Quote #111480
I just pm'd you with my contact information if you need help determining how to upgrade. Thanks Dean
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
1 2 3 >
Premium support services
  • Dedicated premium support services provided by core developers are intended for persons who run mission critical websites, work on projects with tight deadlines, or want to get dedicated support.
Professional services
  • Want to open a new store? Want to take your store to the next level? Need a custom extension? We can customize nopCommerce to fit your store perfectly. Request a quote to get started.
eCommerce CONFERENCE 2019
Learn more