Support for new version reCAPTCHA / V2

< ... < 2 3 4 5 6 >
Posted: March 25, 2018 at 6:57 AM Quote #202367
jojomanzo wrote:
mbalog... I believe it is V3.10 That is what it says under system information.

If it was fixed in 3.9 and we have 3.10 should it be ready for V2 Captcha?  Am I missing a setting? I was hoping to do this for a friend. I saw the instructions on the first page of this thread -- where in the ftp directory do I find those files?

How much would you charge to fix this, since I really am not familiar with the nop system


System information
nopCommerce versionnopCommerce version:   3.10
Operating systemOperating system:   Microsoft Windows NT 6.3.9600.0
ASP.NET infoASP.NET info:   v4.0.30319
Is full trust levelIs full trust level:   True
Server time zoneServer time zone:   Central Standard Time
Server local timeServer local time:   Saturday, March 24, 2018 6:28:52 PM
Greenwich Mean Time (GMT/UTC)Greenwich Mean Time (GMT/UTC):   Saturday, March 24, 2018 11:28:52 PM
HTTP_HOST is used when you have run a multi-store solution to determine the current store.HTTP_HOST:   totalmartialartsupplies.com
A list of loaded assembliesLoaded assemblies:   Show

Since Captcha v1 is no longer supported at the end of this month... will V2 be implemented automatically?

I was asked by a friend to help get his built-in captcha compliant, but I am quickly learning this is not a simple html page I can edit inside this NOP commerce.

I have access to NOP admin, and I have access to his FTP account.

How do I go about changing this for him? Is there a quick "update" button, or is NOP still releasing the backend with the soon to be out-of-date V1?

Thanks

They fixed it in v3.9. Older versions have not been fixed. That's why I've been fixing them and putting them on my site for sale.

The instructions earlier in this thread is what I've been doing and it is working fine.
What version do you need? I've completed 2.7, 3.4 and 3.5.


That would be version 3.1, there is no three ten, after 3.9 they went to 4.00

I've been selling the files to fix these for $39.99 in my store. Just a little something to cover my time.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Effective-Systems.net
Posted: March 26, 2018 at 8:07 AM Quote #202423
Sure, I understand you are selling it, but will you also install it? I have no experience with C++ or Visual Studio, so I would like to be able to give the client the contact information for someone who can take his FTP info and fix the problem.  

If you can do that for $40, or $40 + hour/labor, etc, let me know, and let me know how he can get in touch with you.

Thanks

mbalog wrote:
mbalog... I believe it is V3.10 That is what it says under system information.

If it was fixed in 3.9 and we have 3.10 should it be ready for V2 Captcha?  Am I missing a setting? I was hoping to do this for a friend. I saw the instructions on the first page of this thread -- where in the ftp directory do I find those files?

How much would you charge to fix this, since I really am not familiar with the nop system


System information
nopCommerce versionnopCommerce version:   3.10
Operating systemOperating system:   Microsoft Windows NT 6.3.9600.0
ASP.NET infoASP.NET info:   v4.0.30319
Is full trust levelIs full trust level:   True
Server time zoneServer time zone:   Central Standard Time
Server local timeServer local time:   Saturday, March 24, 2018 6:28:52 PM
Greenwich Mean Time (GMT/UTC)Greenwich Mean Time (GMT/UTC):   Saturday, March 24, 2018 11:28:52 PM
HTTP_HOST is used when you have run a multi-store solution to determine the current store.HTTP_HOST:   totalmartialartsupplies.com
A list of loaded assembliesLoaded assemblies:   Show

Since Captcha v1 is no longer supported at the end of this month... will V2 be implemented automatically?

I was asked by a friend to help get his built-in captcha compliant, but I am quickly learning this is not a simple html page I can edit inside this NOP commerce.

I have access to NOP admin, and I have access to his FTP account.

How do I go about changing this for him? Is there a quick "update" button, or is NOP still releasing the backend with the soon to be out-of-date V1?

Thanks

They fixed it in v3.9. Older versions have not been fixed. That's why I've been fixing them and putting them on my site for sale.

The instructions earlier in this thread is what I've been doing and it is working fine.
What version do you need? I've completed 2.7, 3.4 and 3.5.

That would be version 3.1, there is no three ten, after 3.9 they went to 4.00

I've been selling the files to fix these for $39.99 in my store. Just a little something to cover my time.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: March 26, 2018 at 9:34 AM Quote #202428
preachur wrote:
We have a 3.6 and a 3.7 and need it. We have insynch for MAS and upgrading them will be a long process. Right now we have no captcha.


reCaptcha V2 updates for nop V3.6 and V3.7 are now in my store
http://www.Effective-systems.net
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Effective-Systems.net
Posted: March 26, 2018 at 9:36 AM Quote #202429
The update for reCaptcha V2 for nop V 3.1 is now in my store at
http://www.effective-systems.net

Give it a try, if you have FTP access, it's just a matter of replacing some files and regenerating the reCaptcha keys on Google. The instructions are included in the download.

If you still can't figure it out, then PM me and I'll help.

jojomanzo wrote:
Sure, I understand you are selling it, but will you also install it? I have no experience with C++ or Visual Studio, so I would like to be able to give the client the contact information for someone who can take his FTP info and fix the problem.  

If you can do that for $40, or $40 + hour/labor, etc, let me know, and let me know how he can get in touch with you.

Thanks

mbalog... I believe it is V3.10 That is what it says under system information.

If it was fixed in 3.9 and we have 3.10 should it be ready for V2 Captcha?  Am I missing a setting? I was hoping to do this for a friend. I saw the instructions on the first page of this thread -- where in the ftp directory do I find those files?

How much would you charge to fix this, since I really am not familiar with the nop system


System information
nopCommerce versionnopCommerce version:   3.10
Operating systemOperating system:   Microsoft Windows NT 6.3.9600.0
ASP.NET infoASP.NET info:   v4.0.30319
Is full trust levelIs full trust level:   True
Server time zoneServer time zone:   Central Standard Time
Server local timeServer local time:   Saturday, March 24, 2018 6:28:52 PM
Greenwich Mean Time (GMT/UTC)Greenwich Mean Time (GMT/UTC):   Saturday, March 24, 2018 11:28:52 PM
HTTP_HOST is used when you have run a multi-store solution to determine the current store.HTTP_HOST:   totalmartialartsupplies.com
A list of loaded assembliesLoaded assemblies:   Show

Since Captcha v1 is no longer supported at the end of this month... will V2 be implemented automatically?

I was asked by a friend to help get his built-in captcha compliant, but I am quickly learning this is not a simple html page I can edit inside this NOP commerce.

I have access to NOP admin, and I have access to his FTP account.

How do I go about changing this for him? Is there a quick "update" button, or is NOP still releasing the backend with the soon to be out-of-date V1?

Thanks

They fixed it in v3.9. Older versions have not been fixed. That's why I've been fixing them and putting them on my site for sale.

The instructions earlier in this thread is what I've been doing and it is working fine.
What version do you need? I've completed 2.7, 3.4 and 3.5.

That would be version 3.1, there is no three ten, after 3.9 they went to 4.00

I've been selling the files to fix these for $39.99 in my store. Just a little something to cover my time.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Effective-Systems.net
Posted: March 26, 2018 at 11:28 AM Quote #202437
mbalog wrote:
We have a 3.6 and a 3.7 and need it. We have insynch for MAS and upgrading them will be a long process. Right now we have no captcha.

reCaptcha V2 updates for nop V3.6 and V3.7 are now in my store
http://www.Effective-systems.net


I got 3.6 but accidentally added 3.5 to the cart instead of 3.7. Could you exchange that for us please? We don't have a 3.5 site. We need 3.7. Sorry for the mistake, and thanks in advance.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: April 09, 2018 at 10:56 AM Quote #202984
Thank you Peter for the code provided. I just used it to upgrade a 3.1 and 3.5 site. One thing about the 3.1 worth mentioning - be careful if you use NuGet to obtain the reCAPTCHA4net package as it will update other dlls which will then prevent the project from compiling. To avoid this I downloaded the reCAPTCHA4net package (and the Newtonsoft.Json.6.0.7 it did require) seperately and manually added them. It then worked alongside all the other dll versions referenced by the 3.1 Nop.Web.Framework project and compiled without issue.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: April 15, 2018 at 8:57 PM Quote #203210
My site failed because of reCAPTCHA v1, and I assumed that if I upgraded my site to nopCommerce 4.00 it would be using the current (working) version of reCAPTCHA.

That does not appear to be the case. I was able to get my site upgraded to 4.00, but it is still failing with an error about reCAPTCHA being an unsupported version.

Does nopCommerce 4.00 not yet support the current reCAPTCHA? Doesn't this mean that essentially all stores running on this software are now down?

Or is there a way to get the store to use v2 and my Google-fu is just not up to the task of finding the instructions?

Thank you for any help!
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: April 16, 2018 at 12:35 PM Quote #203271
rockylhotka wrote:
My site failed because of reCAPTCHA v1, and I assumed that if I upgraded my site to nopCommerce 4.00 it would be using the current (working) version of reCAPTCHA.

That does not appear to be the case. I was able to get my site upgraded to 4.00, but it is still failing with an error about reCAPTCHA being an unsupported version.

Does nopCommerce 4.00 not yet support the current reCAPTCHA? Doesn't this mean that essentially all stores running on this software are now down?

Or is there a way to get the store to use v2 and my Google-fu is just not up to the task of finding the instructions?

Thank you for any help!


Could this be as simple as the admin setting is set still to use the 1.0? Go to the admin / settings / general / captcha area, and make sure the "reCAPTCHA version" dropdown is set for "Version 2.0". I believe you need to generate new v2 keys as well.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: April 16, 2018 at 2:59 PM Quote #203274
Thank you! I did find the setting to switch from Version1 to Version2. Unfortunately though the admin screen says it saved the setting, the setting doesn't appear to be changed on a refresh of the page.

Maybe the db upgrade scripts I ran didn't correctly update the database? Though you'd think then the page wouldn't indicate success when saving the settings?
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: April 16, 2018 at 3:13 PM Quote #203275
rockylhotka wrote:
Thank you! I did find the setting to switch from Version1 to Version2. Unfortunately though the admin screen says it saved the setting, the setting doesn't appear to be changed on a refresh of the page.

Maybe the db upgrade scripts I ran didn't correctly update the database? Though you'd think then the page wouldn't indicate success when saving the settings?


What version of nop were you upgrading to 4 from? v2 of recaptcha has been support from version 3.8 on, so if you've upgraded from 3.8 or 3.9 to 4.0 there's likely nothing wrong with your upgrade. Have you tried simply clearing the cache and restarting the website from nop admin? (on 4.0 both options are at the far right on the admin top nav under the gears icon)
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
< ... < 2 3 4 5 6 >
Premium support services
  • Dedicated premium support services provided by core developers are intended for persons who run mission critical websites, work on projects with tight deadlines, or want to get dedicated support.
Professional services
  • Want to open a new store? Want to take your store to the next level? Need a custom extension? We can customize nopCommerce to fit your store perfectly. Request a quote to get started.
eCommerce CONFERENCE 2019
Learn more