Bug in Ajax HTML editor

Posted: May 11, 2010 at 2:42 PM Quote #17303
Just found out a bug in AJAX HTML editor (one more reason to request nopCommerce team to switch back to Fckeditor in 1.6 version [for product details and topic section])

If we add any video (let's say "YouTube" video) in product details [Long Description], once we save the changes, we are not able to access that product from Mozilla

ok let me explain you step by step: (please follow the steps along with the screenshot to understand the situation)

1) If i want to display a you tube video in any product's Long Description area, i will copy the embedded code from you tube view

2) Here I insert the code:

http://www.3dactorsguild.com/VideoEmbed3.jpg]http://www.3dactorsguild.com/VideoEmbed3.jpg

3) Here I preview it in the admin area:

http://www.3dactorsguild.com/VideoEmbed4.jpg]http://www.3dactorsguild.com/VideoEmbed4.jpg

4) Here it is in the public store:

http://www.3dactorsguild.com/VideoEmbed5.jpg]http://www.3dactorsguild.com/VideoEmbed5.jpg

5) Then I go back to the admin area: (and i cannot access the product again - only see 3 buttons that's it nothing else )
http://www.3dactorsguild.com/VideoEmbed6.jpg
http://www.3dactorsguild.com/VideoEmbed6.jpg

[b]This bug is only when we do all these things in Mozilla, in Internet Explorer it takes time to load the page but eventually it works but in Mozilla , it never works which makes it a bug of AJAX HTML Editor
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
FREE nopCommerce Support? Visit www.StrivingProgrammers.com

Best place for FREE nopCommerce Themes & Plugins

www.StrivingProgrammers.com
A trusted community for developers & web-design enthusiast

http://www.StrivingProgrammers.com/blog
Browse hundreds of FREE how-to tutorials
Posted: May 20, 2010 at 3:37 PM Quote #17831
I can confirm this bug in Firefox 3.6.3.

IE 8 seems fine.

Haven't tested other browsers.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: July 05, 2010 at 7:00 AM Quote #20635
Bug confirmed !

Firefox 3.6.3 : You can't edit anymore after adding the embed code for a video.

IE 8 [Browser Mode IE8]: Working fine.
IE 8 [Browser Mode IE7]: Working fine.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: August 17, 2010 at 3:39 PM Quote #23321
I have the same problem when using chrome and firefox.
Do you have some correct solution? (without using IE)
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: August 18, 2010 at 8:12 PM Quote #23423
The problem is in the AjaxControlToolkit. I reported this bug just last week to the project.  In DesignPanel.pre.js, line 426, there is a typo:

tthis._editPanel.get_imagePath_flash())

change tthis to this, recompile, and all works as expected for embedded objects.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Premium support services
  • Dedicated premium support services provided by core developers are intended for persons who run mission critical websites, work on projects with tight deadlines, or want to get dedicated support.
Professional services
  • Want to open a new store? Want to take your store to the next level? Need a custom extension? We can customize nopCommerce to fit your store perfectly. Request a quote to get started.
eCommerce CONFERENCE 2017
Learn more