The 5th annual nopCommerce conference will take place in India on the 10th-11th of October. Please find more about this event here

Assembly dependencies missing when publishing Nop 4.20

Posted: July 11, 2019 at 5:52 PM Quote #242440
Hello all:

I have upgraded my site to Nop 4.20 (from 3.80) and have all the files extracted properly and published on my hosting server (Smarterasp). Please note that I am using the no-source package.

However, I am getting the following message:
An assembly specified in the application dependencies manifest (Nop.Web.deps.json) was not found:
package: 'runtime.win-x64.Microsoft.NETCore.App', version: '2.2.3'
path: 'runtimes/win-x64/lib/netcoreapp2.2/Microsoft.CSharp.dll'

As a result, my website is currently not running.

Can someone assist? I have also sent the same feedback to my hosting provider, in case the issue is at their end but am desperately wanting to fix the issue asap.

Thanks all!
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Posted: July 11, 2019 at 9:59 PM Quote #242453
Issue being resolved with hosting provider. Thanks!
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Premium support services
  • Dedicated premium support services provided by core developers are intended for persons who run mission critical websites, work on projects with tight deadlines, or want to get dedicated support.
Professional services
  • Want to open a new store? Want to take your store to the next level? Need a custom extension? We can customize nopCommerce to fit your store perfectly. Request a quote to get started.
eCommerce CONFERENCE 2019
Learn more