Getting started. Installing and upgrading nopCommerce.

3 years ago
Hi there! Looking through available themes, I came across one which is really good for me, but its just for version 3.5, but I could download only the latest one. How could I make this theme work on 3.7?
3 years ago
Aleks100 wrote:
Hi there! Looking through available themes, I came across one which is really good for me, but its just for version 3.5, but I could download only the latest one. How could I make this theme work on 3.7?


First copy and past the theme to the Presentation==>Nop.Web==>Themes. After that select the theme from front end you will get some error because at nopcommerce 3.7 some properties are added and removed.

Like at "Presentation==>Nop.Web==>Themes==>(nopcommerce3.5 theme)==>Views==>Catalog==>TopMenu.cshtml"

there is a line like

if (Model.RecentlyAddedProductsEnabled)
                {
                    <li><a href="@Url.RouteUrl("RecentlyAddedProducts")">@T("Products.NewProducts")</a>
                    </li>
                }

which is not present at nopcommerce 3.7's TopMenu.cshtml. So what you need to change to make it works you need to go to the default nopcomeerce 3.7's "TopMenu.cshtml" and see what are the changes of this view occur at nopcommerce 3.7 then change the same things at your nopcommerce 3.5's theme.

In short where you face error try to see the default view and fix it at the nopcommerce 3.5's theme.
3 years ago
Hi
I have installed nopcommerce , however I get to the stage were I need to start the site for the first time however every time I try to create the site admin email address and password it gives me an error saying database does not exist or I do not have permission to connect to the database,Yet I have access and admin rights.

Please can you confirm what username and password is used here , as I am using the username and password I created on the nopcomerce sight when I registered. I also tried to use my windows auth login and that also won't work.

Please assist.
olivia
[email protected]
3 years ago
PLease ignore post , managed to login to site, thanx
3 years ago
richardrcruzc wrote:
Hi NOP land - I am trying to change my logo on the front page. I have asked this question before and lost the link.  Can anyone help. or suggeset

Thanks

Des

need to modify on the themes folder,  the file style.css a.logo{background:url(images/logo.gif);display:block;width:225px;height:60px;text-decoration:none;}
for the darkorange, nopclassic if your are using the nop default themes, if you're using nop 2.30


Please visit us at http://blog.envissolutions.com/post/2016/07/03/nopcommerce-3-7-not-installing-catologs-properly  you will get solutions over your problem.
3 years ago
Hi All

I want to add the admin panel on sub domain as like in demo. How we will achieve this.
How we will publish admin panel. What is process?

Thanks
3 years ago
Please can you tell me, is nopcommerce 3.7 is supporting ccavenue?

a.m. wrote:
Thanks!



Are there any special instructions when previous version is 1.x?
No. They're the same as for all versions. Just download the upgrade scripts and follow the instructions in readme.txt file
3 years ago
rakeshthakre wrote:
Please can you tell me, is nopcommerce 3.7 is supporting ccavenue?


Yes, supported
3 years ago
I tried just running the upgrade scripts on the DB until the desired version, then launching that version's web files. It failed.

I assume we need to run the DB upgrade for each version between the starting point and desired endpoint .. then we must also launch the site once to compile before proceeding.

Then run the next upgrade script and launch the new site version again .. over and over until we reach the desired version.

Am I correct that we cannot just run the database upgrade scripts in series without launching (compiling) the site at least once for each version  before proceeding to upgrading the database to the next version?
3 years ago
Just downloaded v3.80 from your site, when trying to compile on VS 2015 I get the following error:
"Unable to launch the IIS Web Server, Port '15536' is already in use - anyone else get this error or
know how to resolve?
Thanks.