look for sendgrid plugin 3.70

10 months ago
I am looking for sendgrid plugin version 3.70.

Thank You,
Emilie
10 months ago
Hello Emilie,

Kindly check your PM.

Thanks,
Jatin
10 months ago
Hi Emilie,

I can help you with your requirement. Please check my email and PM.

Regards,
Vincent