Upgrading 4.10 to 4.20 File permissions

8 months ago
Curious if file permissions are the same as listed in the documentation. Tried upgrading my site and getting a 403 Forbidden error. Seems like there may be a permissions issue, but haven't been able to track anything down so far. Here is what I've done to this point.

I've followed the upgrade documentation located here: http://docs.nopcommerce.com/display/en/Upgrading+nopCommerce
Backed up site files as well as database. Cleaned out the site files, uploaded 4.20 files, copied backup files of wwwroot/Images and App_Data/InstalledPlugins.json and App_Data/dataSettings.json

I've given the correct permissions following the installation guide
For nopCommerce versions 4.00 and above: Some folders were named a differently or missing all together.

\App_Data\
\bin\          `Folder didn't exist
\log\          `New folder named 'Logs'
\Plugins\
\Plugins\bin\
\wwwroot\bin\          `Folder didn't exist
\wwwroot\bundles\
\wwwroot\db_backups\
\wwwroot\files\exportimport\
\wwwroot\images\
\wwwroot\images\thumbs\
\wwwroot\images\uploaded
\App_Data\installedPlugins.json (after installation)
\App_Data\dataSettings.json (after installation)
8 months ago
Still nothing. I tried the entire process again to double check my procedure.

Also checking with SmarterASP (my hosting provider) to make sure .Net Core 2.2 is running on my server. They document that they support it. https://www.smarterasp.net/support/kb/a1986/supported-versions-of-_net-core.aspx

Currently will be reverting back to 4.10 until I figure out what may be going on.
8 months ago
Hosting provider changed something up on their end. Upgrade went through and now I'm able to see 4.20 pages.

However... Public store shows products, but the admin side isn't showing any products, customers, orders, etc. Something is off. See images of admin area.

https://drive.google.com/open?id=1oGSF6SBA-5rxUB57BFa1HavbnvK1pJ7Q
8 months ago
Hi,

I had the exact same screens showing up after my upgrade.

My problem was my browser cache (Chrome), would not get the updated css/js files, since they all named the same as previous version.  
Solution, clear browser cache, close it and try again.

Hope it's as simple as that for you too.