[Nop 4.1] Cache problem... cart products doubled / missing...

4 months ago
Hi, we don't know how reproduce this problem. And we don't know how many of our Clients are affected this behaviour… and abandon our page.


Sometimes our Clients describe problems with shop looks a like:
1. Adding product to empty cart + 1 pcs…
2. Go to Real One Page Checkout (NopTemplates), and there see 2 similar products or other earlier adding.
3. Client try to remove products from cart, reduce 1 pcs… and his cart is suddenly empty…
4. Add again product 1 pcs… and see 2 products...

Have anybody similar problem?


We last week combine css's to one file, and nothing more we are change?
4 months ago
Hmm… maybe it's not cache problem. Clients is first time on our page. No errors in logs :/


Anyone have idea how in this situation we can test / try reproduce it? what can make this problems? O_O
3 months ago
Hello Zyje_sobie,

are you still having issues like that? If so, please go to our site and submit a ticket for this and include a step by step guide of how we can reproduce the issue, so we can investigate what the problem might be. Does this happen only with certain products or all of them?

Looking forward to your answer!

Best Regards,
Valentin.
3 months ago
Nop-Templates.com wrote:
Hello Zyje_sobie,

are you still having issues like that? If so, please go to our site and submit a ticket for this and include a step by step guide of how we can reproduce the issue, so we can investigate what the problem might be. Does this happen only with certain products or all of them?

Looking forward to your answer!

Best Regards,
Valentin.


Hi! i'm actual without your support, so can't open ticket :(. It's happen in really weird situations...

I had similar behaviour only 1 time... but i tried to reproduce it: test / click / restart / css change etc. etc. / but without success.

Problem is with some users... but i don't know how to reproduce it. :(

I think maybe it's our plugin where we add feature from NOP 3.7 to set product position in category (it's removed from product admin panel for some reason).

I saw situation when we  sometimes change lots products and their positions in categories.. from some reason products are not moved to their "position from sets" (for example product should show on the last page of category, but for some reason "clear cache" ctrl + F5, don't moved it and still is on first page. Only re-index change it.

Also in some situation when we add new product we see them on the "newproducts" page, but when we click on them we have 404. In admin panel "seo link" is empty (blank space). And we need clear cache to fix it (maybe it's only on local computers).

Well and that's all what i think it's maybe corelated... but don't know reason.

I tried find documentary about "cache sets" in nopcommerce, but without success.
3 months ago
1) have you customize or extend feature using plugin?
2) if you are using plugin then you have to disable third party plugin one by one and need to check the issue. means  from which plugin you are facing issue.