Getting started. Installing and upgrading nopCommerce.

3 months ago
kmsrao wrote:


hi,
if u have a solution give here, i m not a devoloper.

best regards
cebina

Hi
I understand from your previous post that you used Source Code and it is working. If you are looking for binaries for linux you can get them at https://github.com/kmsrao/NopCommerce_Linux/  . Hope it helps.


Thank u kmsrao its working!
3 months ago
Good to hear.
3 months ago
cebina wrote:


Thank u kmsrao its working!


Hi Cebina

By Default, the dotnet runs at 5000 port.

if you want to run another instance from a different port (eg: 5050),  the command is
dotnet run --urls=http://localhost:5050/

Nginx can be set (at a different port from first nignx service)  to listen to this port  (5050).

Thanks
kmsrao.
3 months ago
Hi,

I'm trying to setup nopCommerce on ubuntu server 19.10. I followed the instructions in this guide "https://docs.nopcommerce.com/user-guide/installing/linux.html" but ran into a BadImageFormatException on a few assemblies.

I decided to compile from source using my mac laptop and tested everything before deploying to the ubuntu server. Everything was working fine on my mac but when I deployed to the ubuntu server I got this error "Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware[3] An exception was thrown attempting to execute the error handler. System.InvalidOperationException: Cannot find compilation library location for package 'Microsoft.Win32.Registry'...."

I decided to create a ubuntu VM and tested it on the VM and got that same error. Then I setup a ubuntu dev machine and the source using the ubuntu VM and everything worked great again. However, when I deployed the assemblies compiled with the ubuntu VM to the ubuntu server I got the same error but with different package "Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware[3]
      An exception was thrown attempting to execute the error handler.
System.InvalidOperationException: Cannot find compilation library location for package 'System.Diagnostics.DiagnosticSource'...."

I'm really out of idea. Should I install the SDK on the server and compile the source on the server? Maybe someone here have seen the issue before and can help point me to the right direction.

Thanks!
3 months ago
The publish should work good as long as the run time is set as Linux 64.  Please make sure all the dependant dlls are present in the publish directory.  For reference you can refer to my github path for the linux library.
3 months ago
Thanks, kmsrao! I'll try the compiled version from your github page.

By the way, I did installed the SDK on my Ubuntu Server and compiled the source on the server and it's working now. I know that is not how it should be done but I've tried many methods and that's the only method that is working so far.

Do you mind sharing how you build nopCommerce for linux 64bit? How did you setup your dev environment and what's the command line that you used to build nopCommerce?

-- Thanks
3 months ago
I tried Visual Studio on Windows System , SDK  in Windows System and  SDK in Ubuntu. All three works.  In all the cases,

dotnet publish  --self-contained true  --configuration Release  --runtime linux-x64
3 months ago
Thanks, kmsrao! That's the command I need.

--thank you.
2 months ago
I was pleased and excited to see the Beta download for the new version that will allow the use of MySQL.

Having downloaded the No Source Code option, I am stuck!  I may well be missing the obvious but I cannot find and do not understand how I had NopCommerce to my website - I assumed that I need to embed a link to Nop.Web but that is not working - my question is how do I add NopCommerce to my website pages?

From searching and reading your install information I have added Read / Write permissions to the list of directories

I am hosting on Godaddy with a Plesk control panel. IIS is installed and I am told it has Core 2.2

Framework is 4.8

Thank you

Regards
2 months ago
David,
Is your Godaddy server on a shared host or a VPS server?

v4.30 Beta requires Dotnet 3.1 running on the server, if your on a VPS you can remote into your server and install dotnet 3.1 and the AspNetHosting package as in the the release notes here https://www.nopcommerce.com/boards/topic/80146/nopcommerce-430-beta-released-please-share-your-impressions#260201
If your on a shared host you most likely won't be able to do this yourself. You might ask tech support if they will install, but my past experience is they will not and that is why I moved to VPS server a few years back.
What your seeing in the plesk panel is limited as to what is actually installed on your MSServer version which is probably v2012 or v2016.
Hope this helps!