Getting started. Installing and upgrading nopCommerce.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.
2 years ago
I tried using VS19 instead of VS17 and have this build problem . . . " ..\Nop.Core\Nop.Core.csproj' targets 'netcoreapp2.2'. It cannot be referenced by a project that targets '.NETFramework,Version=[InsertAnyVersion#Here] ".  Any suggestions? Thank you in advance!
2 years ago
dojodon wrote:
I tried using VS19 instead of VS17 and have this build problem . . . " ..\Nop.Core\Nop.Core.csproj' targets 'netcoreapp2.2'. It cannot be referenced by a project that targets '.NETFramework,Version=[InsertAnyVersion#Here] ".  Any suggestions? Thank you in advance!


Make sure you installed the correct version and bit of SDK.  v2.2 must be installed for VS19.

Go to the Nop.Web -> Options -> Under Applications tab check the SDK Version if there is no 2.2 just click on Install Other Frameworks and install 2.2 for VS19
1 year ago
how to install nopCommerce
1 year ago
https://docs.nopcommerce.com/en/installation-and-upgrading/index.html
Can you post more specific questions ?
1 year ago
I want to upgrade my application of version 4.1.

Is there any way to merge new version file to my existing version file(4.1), so that no need to replace existing file ?
1 year ago
@[email protected]
Please don't duplicate topics/questions
1 year ago
Where can I find the SQL upgrade scripts to upgrade from 4.2 to 4.3?

Thank you in advance.
1 year ago
SorgoRojo wrote:
Where can I find the SQL upgrade scripts to upgrade from 4.2 to 4.3?

You can find here.
1 year ago
I want to upgrade from 3.8 to 4.4
I checked upgrade script https://www.nopcommerce.com/download-nopcommerce-link?type=upgradescript and it says we don't use SQL upgrade scripts anymore, upgrade is performed automatically with migrations.

So my question is to upgrade 3.8 should i download 4.4 against existing database and when i run the application it will automatically perform migration from 3.8 to 4.4?
1 year ago
Hi Adeel,

You have to first upgrade DB from 3.8 to 3.90, 3.90 to 4.00, 4.00 to 4.10, 4.10 to 4.20, 4.20 to 4.30
and then update/replace your code/files with nopCommerce 4.40.0/4.40.2. This will automatic update your db to 4.40.0 compatible as auto migration added in code.
This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.