Nop 2.4 runtime error

8 years ago
Downloaded Source Code for Nop 2.4

brand new project.

Installed MVC 4.0

Changed System.web.webpages to be 2.0.0.0

Project Builds, But get a runtime error.

Method 'ValidatePaymentForm' in type 'Nop.Plugin.Payments.AuthorizeNet.Controllers.PaymentAuthorizeNetController' from assembly 'Nop.Plugin.Payments.AuthorizeNet, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' does not have an implementation.

Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
8 years ago
manojmodi wrote:
Installed MVC 4.0

You need MVC 3
8 years ago
I have  the same problem.
I have installed both MVC3 and MVC4.
Whic versión of System.Web.WebPages I must use: 1 or 2?
8 years ago
https://www.nopcommerce.com/boards/t/14655/compile-error-conflict-between-different-versions-nopweb.aspx
7 years ago
I deleted the references to System.Web.MVC in each of the Payment Plugins.

Then added a reference to System.Web.MVC version 3.0.0.0

Now it works.
7 years ago
Or you can point to DLL included into Nop Source packages folder

..._Sources\nopCommerce_2.65_Source\packages\aspnetmvc\System.Web.Mvc.dll