Server Error in '/' Application when publish to Azure

5 years ago
Hi thanks for your post. Yes that seems to be the case. What ive noticed is settings.txt (which holds the connection string, and works when on local host) is not published. Now i have placed this in the directory on the server with ftp... but this then throws the error DNS_PROBE_FINISHED_NXDOMAIN... which is a web page not available error. Its like if i  put in the settings.txt file the page is not even found to throw the connection string null error.

Ive looked in the directory of the site i copied the source code and settings.txt is not present there.

I feel like the settings.txt file should be incorporated into the compiled version that is published to azure....

Any ideas?

Thanks
5 years ago
Okay so here is what i found.

The statement of the DNS_PROBE_FINISHED_NXDOMAIN error if settings.txt is present in App_Data is 100% correct. The problem is the URL Azure provides http://yourwebsite.azurewebsites.net/ does not work, and its not until the custom domains are hooked up and used to navigate to the website that the site runs as expected.

Thanks
4 years ago
also having
DNS_PROBE_FINISHED_NXDOMAIN
4 years ago
kinjo wrote:
also having
DNS_PROBE_FINISHED_NXDOMAIN

got the fix
http://www.deskdecode.com/dns_probe_finished_nxdomain/
3 years ago
You can Fix this error very easily.

First you need to open cmd.

After then run “ipconfig /flushdns”

Now just restart your computer and check, Now your computer is ok.
1 year ago
Open Start > Settings > Network & Internet > Status
Scroll down to the bottom then click Network reset

If that does not work.

press Windows key + X
Click Device Manager
Expand Network adapters

Right click your adapter
Click Uninstall

Exit Device Manager, restart. Windows 10 should detect the network adapter then reinstall it. Check if you can connect and browse.
1 year ago
kinjo wrote:
also having
DNS_PROBE_FINISHED_NXDOMAIN



I had a similar problem after I upgraded the modem for my BigPond Cable to Telstra Gateway Max at the end of 2018.
My PC was running Windows 10 and was connected through Ethernet cable to my modem.

I tried the solutions that I found on Google https://techloris.com/dns_probe_finished_nxdomain/

The problem seemed to have disappeared.

But I had no idea if it was solved by either:

1. Using a different connection and modem (NBN instead Cable)

or

2. The Windows 10 update that was installed on my PC.

Anyway, I am happy that I can not have the same issue again.
1 year ago
Hello, many chrome users have this error, but you can easy fix it try one of these methods:
1. Flush DNS
2. Restart DNS
3. Configure DNS server adresses
4. Reset hosts file

I will share really easy tutorial how to fix DNS_PROBE_FINISHED_NXDOMAIN.
Full Guide : https://www.hows.tech/2019/05/DNS-PROBE-FINISHED-NXDOMAIN-error-chrome-soluton.html
11 months ago
Most easy fix change dns to 8.8.8.8 and 8.8.4.4

https://geeksadvice.com/how-to-fix-dns_probe_finished_nxdomain-error/
11 months ago
Zac.Hall wrote:
but this then throws the error DNS_PROBE_FINISHED_NXDOMAIN... which is a web page not available error.


It means that the DNS service is not working properly on either your side or the server's side. Changing DNS server to Google DNS or OpenDNS , or remove all cookies and cached files on your browser will help to resolve this issue immediately. Like any other error, there are several ways you can solve DNS_PROBE_FINISHED_NXDOMAIN problems by yourself.

    Release or Renew Your IP Address
    Change DNS server
    Restart DNS Client service
    Reset hosts file
    Reset Chrome Flags
    Reset Winsock program