non-WWW redirect not work for https

3 years ago
Nop3.9, My setting

WWW prefix requirement: Pages should have WWW prefix
Force SSL for all site pages: (checked)

Store URL: https://www.mystore.com/
SSL enabled: (checked)
Secure URL: https://www.mystore.com/
Host Values: mystore.com,www.mystore.com

When I typed mystore.com and www.mystore.com, both work well in redirecting to https://www.mystore.com
But I typed https://mystore.com, it's not redirected to https://www.mystore.com

Is it a bug or I missed a setting?

Z
3 years ago
In IIS, you are missing the https site binding for YOURDOMAIN.COM (without the www.)
Just create a new binding for it and leave all of your settings as they are and it will work fine.

Your certificate probably doesn't cover the root level domain, but not to worry..you can create the binding anyway.
10 months ago
zhugefs wrote:
Nop3.9, My setting

WWW prefix requirement: Pages should have WWW prefix
Force SSL for all site pages: (checked)

Store URL: https://www.mystore.com/
SSL enabled: (checked)
Secure URL: https://www.mystore.com/
Host Values: mystore.com,www.mystore.com

When I typed mystore.com and www.mystore.com, both work well in redirecting to https://www.mystore.com
But I typed https://mystore.com, it's not redirected to https://www.mystore.com

Is it a bug or I missed a setting?

Z


Did anyone get a solution for this?
2 months ago
The answer provided by embryo works. But need to have certificate for  www and non www url.
i.e. www.mystore.com and mystore.com