Serious IIS Application Pool recycling bug/design flaw

2 years ago
Our current appsettings.json

    "ClearPluginShadowDirectoryOnStartup": true,
    "CopyLockedPluginAssembilesToSubdirectoriesOnStartup": false,
    "UsePluginsShadowCopy": true,
    "UseUnsafeLoadAssembly": true,

Per the Azure installation guidance make the following change:
"UsePluginsShadowCopy": false
2 years ago
Will try! Thank you!
2 years ago
And check the list of unused and uninstalled plugins.
Remove them from the folder Plugins.
2 years ago
Fix:  Disable overlapped application pool recycling.  

In your Azure web app, create this applicationHost transformation in the \sites\ folder.  Name the file applicationHost.xdt.   Don't put it in wwwroot, put it in the parent of wwwroot X:\home\sites\

<?xml version="1.0"?>
<configuration xmlns:xdt="">>
      <add name="dev-yoursitename" xdt:Locator="Match(name)">
        <recycling disallowOverlappingRotation="true" xdt:Transform="Insert" />
      <add name="~1dev-yoursitename" xdt:Locator="Match(name)">
        <recycling disallowOverlappingRotation="true" xdt:Transform="Insert" />

Replace the dev-yoursitename and ~1dev-yoursite name with the values from a powershell command run in KUDU: echo %WEBSITE_SITE_NAME% and echo %WEBSITE_IIS_SITE_NAME%

If you want to be able to deploy this fix, add the file to your Nop Presentation folder (next to web.config) and set to Copy Always.  Then, in the pipeline release deployment, in the Azure App Service Deploy task, add a Post Deployment Action

cp applicationHost.xdt ../
2 years ago
i faced this issue with smarterasp shared hosing using nop 4.2 and i can't disable app pool recycling it should be VPS.
is there another solution either upgrade the hosting plan ?
1 year ago
Hi there,
I have the same exact issue. The application restarts exactly in every 29 hours.

Application settings are:
    "ClearPluginShadowDirectoryOnStartup": true,
    "CopyLockedPluginAssembilesToSubdirectoriesOnStartup": true,
   "UsePluginsShadowCopy": false,
    "UseUnsafeLoadAssembly": true,

Plugin/bin folder is empty.

May i ask you if this is related to any folder access permissions of application pool?
1 year ago
I kind of solved this problem. There are two things that I changed, and the issue is resolved.
1. First, I changed the application pool settings in IIS.
Idle time-out (minutes): 0
Regular time interval (minutes): 0

2. I deleted the uninstalled plugins. There was a mailchimp plugin which was outdated, I updated and installed it.

So I have no error, or application restart for the last 4 days.
I hope this would help.
6 months ago
We seem to still have this issue in 4.3 but we are not on Azure. We moved our customer from 4.1 to 4.3 hoping the issue would have been resolved but we still have the issue on a regular basis. Any ideas for version 4.3?
2 months ago
Hello Guys,

We are getting the same issue in nopCommerce 4.40.4 as well.

We have disabled application pool recycle from Application pool but still, sometimes we are getting this same error of shadow copy one.