Version 4.0 - Registration Email not Send - The request was aborted: Could not create SSL/TLS secure channel.

2 years ago
Hi,

When I test the email account set for the shop to send emails, everything works fine, I receive the email correctly.

When I set the option to get a notification of a new registration or a confirmation email of the registration, I get the error: The request was aborted: Could not create SSL/TLS secure channel.

Any idea why?

My server is a Windows Server 2008 R2.
2 years ago
Hello,

If the problem is regarding ssl than you have to look at

http://admin-demo.nopcommerce.com/Admin/Setting/GeneralCommon.

In which you can find Force SSL for all site pages.

It should be enable.

Restart your application from admin panel.

May be it would be helpful to you.
2 years ago
Hi, Thank you for your response, but it's enabled :(
2 years ago
Try connecting to your SMTP server without TLS.

Or follow this link to setup TLS 1.2 on your site: https://www.nopcommerce.com/boards/t/47248/nopcommerces-paymentauthorizenet-free-plugin-is-tls-12-supported.aspx#187454


2 years ago
Hi, thanks but how can I do that in version 4.0? I don't have the Global.asax.cs file now
2 years ago
I have changed the URL of the shop from https://SHOPURL to http://SHOPURL and it started to send the emails, any reason why?
2 years ago
patrick_sardinha wrote:
I have changed the URL of the shop from https://SHOPURL to http://SHOPURL and it started to send the emails, any reason why?


Does you have ssl ?
2 years ago
What do you mean?
2 years ago
I had the same issue.  Discovered that TLS1.2 was not enabled at the OS level (Win2008 R2)...
Made some changes to the registry as per this page...

https://tecadmin.net/enable-tls-on-windows-server-and-iis/

and hey presto, emails are now being sent using the scheduled task.  Other scheduled tasks started to work too :)

Happy days!
2 years ago
Hi,

I have found the issue, it was related with the fact that the shop's URL was including the https in the url. I have put http instead and it solved the problem.

Thanks.