nopCommerce 4.20 IONOS hosted failing to run scheduled tasks

9 months ago
Hi,

I've built from source, then uploaded and configured nopCommerce on an IONOS Windows hosting package.

However, it seems that the Keep Alive task is failing to run with a connectivity error shown in logs.

I have verified that the store URL is correct, (https://goat-vape.com) and have tried it as "https://www.goat-vape.com", plus I've enabled & disabled forced SSL and site SSL, yet the issue persists.

I can manually open "https://goat-vape.com/keepalive/index" and get a blank page.

Having searched the forums here and carefully tried answers from similar threads, I've still not be able to resolve the issue.

Error:
The "Keep alive" scheduled task failed with the "One or more errors occurred. (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond)" error (Task type: "Nop.Services.Common.KeepAliveTask, Nop.Services". Store name: "G O A T Vape & Coffee Company". Task run address: "https://goat-vape.com/scheduletask/runtask").

Can anyone advise please?
9 months ago
UPDATE: I have completely disabled SSL, yet the task still won't run!
3 months ago
Hi,I have the same problem with ionos?did you resolve the issue ? Thanks
3 months ago
No, the problem appears to be caused by IONOS' hosting setup and I found they were next to useless when it came to technical support or willingness to help me resolve it.

I moved to host the site via Azure in the end, havent had any trouble since.
3 months ago
I have managed to resolve  changing store url from https://xxxxxxx to http://xxxxxxx...
Although ihave enabled ssl in store...
3 months ago
I tried this, but it had a knock on effect dur to IONOS not supporting a https proxy.

I also had Cloudflare enabled with the site, perhaps this was also contributing.

Are you sure its working now? If so I may migrate back to IONOS servers as the pricing is more appealing.
3 months ago
I have made the change barely on hour ago,and scheduled tasks are running fine.
I tell you if i have another issue.
3 months ago
UPDATE:I have found this link https://www.ionos.es/ayuda/hosting/net/ejemplos-de-scripts-para-establecer-conexiones-http-externas-hosting-windows/.
I think ionos setup actively refuse external http request.
I have change proxysettings in database:
proxysettings.enabled:true
proxysettings.address:http://winproxy.server.lan
proxysettings.port:3128
proxysettings.preauthenticate:false
also i have change
//client to request current store
  services.AddHttpClient<StoreHttpClient>().WithProxy();
in AddNopHttpClients method in ServiceCollectionExtensions
revert store url to https://xxxxxx all scheduled task are running ok.
Perhaps someone of nopcommerce Team could give his opinion?

sorry for my english
2 months ago
Thank you pizzadanSl,  I have the same issue with IONOS hosting, I resolved it by updating the proxy setting.
Regards.