Error while running the 'Keep alive' schedule task. The remote server returned an error: (403) Forbidden.

8 months ago
Error I am getting but I have mentioned correct Store URL.
but When I am dig into the error it showing my local path of the source code in Live. I don't know why it is been showing local path on live. (NopCommerce Version 4.9)
Below error I am getting can anyone help me out for the same.

System.Net.WebException: The remote server returned an error: (403) Forbidden. at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request) at System.Net.WebClient.DownloadString(Uri address) at System.Net.WebClient.DownloadString(String address) at Nop.Services.Common.KeepAliveTask.Execute() in V:\Git_ProjectName\ProjectName_FlowChange\ProjectName-FlowChange\Libraries\Nop.Services\Common\KeepAliveTask.cs:line 27 at Nop.Services.Tasks.Task.Execute(Boolean throwException, Boolean dispose, Boolean ensureRunOnOneWebFarmInstance) in V:\Git_ProjectName\ProjectName_FlowChange\ProjectName-FlowChange\Libraries\Nop.Services\Tasks\Task.cs:line 163
8 months ago
You mean the 3.9 version, right? Does your store url end with / sign? I got similar issue and adding / sign at the end of store url solved the issue
8 months ago
Yes Nopcommerce Version 3.90. @sanju.dahal741

Yes My Store URL mentioned correctly below I am sending you my Store URL that I have mentioned in Store Setting. I have changes few of the name as it is confidential so.

Please guide me for the same.

1) Store name  : mystorename  - (Actual is different)
2)Store URL          : http://mystorename.com/ (This is the URL I have mentioned just changed my store name here)
3)SSL enabled  : True
4)Secure URL        : https://mystorename.com/
5) HOST values   : www.mystorename.com,mystorename.com