How to publish and deploy in IIS step by step

5 months ago
Hi All,

Can anyone provide me the details step or documentation how to publish and deploy in IIS ?

I am using nop4.3 version and there is an error in while I am trying to step up in server IIS but getting the error as below "Setup failed: There is already an object named 'nop_splitstring_to_table' in the database."

Thanks and Best Regards,
Aung
5 months ago
aungphyowynn wrote:
Hi All,

Can anyone provide me the details step or documentation how to publish and deploy in IIS ?

I am using nop4.3 version and there is an error in while I am trying to step up in server IIS but getting the error as below "Setup failed: There is already an object named 'nop_splitstring_to_table' in the database."

Thanks and Best Regards,
Aung


Hi Anug,

This document should guide you to install nopcommerce on Windows Server.

Regarding the error, are you installing in on new sql db?

Regards
5 months ago
Hello,

Thank you so much. It helps me.

Thanks and Best Regards,
Aung
5 months ago
Glad to know that it helped.
1 month ago
Hello Guys,
I am trying to set up the nop 4.3 version on our local office server. But no luck.
I am using the "without source code" nopCommerce. I followed all instructions, googled a lot about installation, I installed the files for IIS what .Net Core requires, but I stuck. I have added "192.168.0.10 nop43.com" to the host file.
I try to run the site called "nop43.com" form IIS with the "Browse Website" option and I get this error:
Hmmm… can't reach this page nop43.com’s server IP address could not be found.
Did you mean http://nipic.com/?
Search the web for nop43
ERR_NAME_NOT_RESOLVED

My webconfig file is:
      
<add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
    </handlers>
    <!-- When deploying on Azure, make sure that "dotnet" is installed and the path to it is registered in the PATH environment variable or specify the full path to it -->
    <aspNetCore requestTimeout="23:00:00" processPath=".\Nop.Web.exe" arguments="" stdoutLogEnabled="true" stdoutLogFile=".\logs\stdout" startupTimeLimit="3600" hostingModel="InProcess">


No log files, I think the process is not get there when can write a log entry.

There is another Asp .Net site on IIS (not .Net Core) which is running fine.

Is anybody have any idea?

Many thanks
Zoltan
1 month ago
Not that I am a DNS expert - What happens when you ping 192.168.0.10 ?
This looks like the router address not the host
I have 127.0.0.1    mydomain.com in Hosts file
1 month ago
Hi Yidna,

It is nice to talk to you again.
The 192.168.0.10 is our local server address. The entry in the hostfile makes the website accessible from the local network.
I just added the "127.0.0.1 nop43.com and it didn't help.
I didn't restart the server after I installed the .Net Core things, I only restarted the IIS.
It is night time here, I will restart the server see is it better or not.

I will come back with the result.

Many thanks
Zoltan
1 month ago
After server restart still not working.
1 month ago
Hi Zoltan,

Are you able to run it with localhost:someport? Just to verify that nop is installed correctly and is working before we move to the domain mapping?

Regards,
Krunal
nopAccelerate.com Team
1 month ago
Hi Krunal,

Thank you for your reply.
I can click only the link in IIS, please see the picture.
I think it is like localhost. The IP is our local server IP address.


Thanks in advance.
Zoltan