need help just getting started and am lost on install

11 years ago
i use microsoft web pi 2 rc to install first problam
1. The IIS APPPOOL\DefaultAppPool account is not granted with Modify permission on folder C:\inetpub\wwwroot\nopCommerce\. Although this is not an error, it's highly recommended that you configure these permissions.

How do i fix this
secound problam on step 2

2.
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

how do i fix this
11 years ago
Hello,

There are two types of installation of NopCommerce as described on the web site:

1. Automatic with the installation wizzard.
2. Manual - editing the connection string of the ConnectionStrings.config file. It is on root level of the web site.

Even without these permissions you can edit and publish the ConnectionStrings.config before the final step of the wizard. You should know your SQL database. It looks like this:
<connectionStrings>
    <add name="NopSqlConnection" connectionString="Data Source=putTheNameOfYourServerHere;Initial Catalog=NameOfYourDatabase;Integrated Security=False;Persist Security Info=False;User ID=YourUserID;Password=YourPassword;Connect Timeout=120"/>
</connectionStrings>


There is one more place it will be good to look for additional settings you may need to configure:
https://www.nopcommerce.com/Boards/Topic.aspx?TopicID=314

This should solve your installation problems - it worked for me.

Regards,
Lyubo
11 years ago
well see i do not know miscrosoft sql i could use mysql but i do not think this program lets you use mysql now is there a step by step guide some where from start to end
11 years ago
Hi,

If you follow the install instructions you should be fine.

You only need to know a little ms sql to get you by. If you download the nosource version of nopcommerce you will be able to run the install page. follow this link for install video: https://www.nopcommerce.com/Screencasts/Installation.aspx

If you do not want to do that, there is sql scripts you can run and if you provide a connection string to your connectionstrings.config to get it to work (as previously posted).

There is no support for mysql.

mike..
10 years ago
I have tried the link to watch the video and cannot get it to come up. I have tried IE and Firefox. Is it having problems?

Thanks
10 years ago
Video runs fine from here.

IE8, Win7 Ultimate
10 years ago
Common problem.  If you cant watch the video, you likely have issues with your flash player.  Uninstall the flash player from your control panel, then go to the adobe site and download the latest version.  Here is the link http://get.adobe.com/flashplayer/
8 years ago
Hi,

I'm having trouble installing v2.2... so many errors...
I also tried to run the video mentioned above, it failed to run, IDLed the Falsh update from Adobe still no luck.

Anyone know how to install 2.2?
8 years ago
found solution to my issue... install MVC 3.0
8 years ago
Yep, that seemed to get me all fixed up as well. I posted all the steps here with download files and all. Long story short make sure your framework is completely up to date.

http://ryan.d3-systems.com/how-to-install-nopcommerce-2-2.html