Pictures Come and Go 4.3

2 days ago
I have recently upgraded my site to 4.3.
I am using the default "clean" theme.

My store logo and category images will come and go with no rhyme to reason.

I can go away for an hour and then hit the site, on the homepage - no store logo (no broken link or text, the area is simply blank).  The category images on the homepage all show the text "Picture of category _______" with no image.
All category/product pages are missing the store logo at the top of page. Images on the cat or product page are fine.  

Come back an hour later and the site looks normal again.

This happened on each browser I have tested as well as my phone.

Any idea what causes this behavior and how to fix it?
2 days ago
Are you
using SSL (https://) ?
hosting in Azure?
using a CDN (e.g. Cloudflare)?
2 days ago
Some additional information.

Restarting the app pool will usually fix it.

When it is failing, the broken images info are showing a link to the site IP-address/image, when they are working they show a link to the domain/image.

How are the image links changing between IP and domain name?
2 days ago
New York wrote:
Are you
using SSL (https://) ?
hosting in Azure?
using a CDN (e.g. Cloudflare)?


https://
On a Windows 2016 server and a Windows 2016 SQL server

No cdn, no cloud.
2 days ago
I recall some recent posts about this.  Google  https://www.google.com/search?q=site:nopcommerce.com+IP-address%2Fimage
2 days ago
Thanks for the google search link, it produced a lot of pages of people scratching their heads and not knowing the answer. I figured the NOPCommerce forum would get a better answer.

For those that came here to find the answer, here is what I found. NOP is by default using absolute paths to the images. This causes the problem in that when  NOP/IIS/cache/boogeyman (not sure) uses the IP instead of the SSL bound domain, the images will not show due to the SSL being bound to the domain.

There is a setting for this,
In 4.3 - Admin> Configuration> Settings> All Settings (Advanced)> On page 26, or set sort to 100 records and it is on page 4
mediasettings.useabsoluteimagepath setting this to false looks like it fixes it in the page source. I will update after more testing.
2 days ago
[email protected] wrote:
Any idea what causes this behavior and how to fix it?


You can hopefully mitigate the problem by specifying the domain name in the IIS host headers. This will prevent access to your web browser by ip address.

Under IIS bindings specify  <yourdomain>.com and www.<yourdomain>.com for both port 80 and 443

This problem really needs to be fixed at a source code level.