Find bugs in nopCommerce 4.40 BETA and earn $10

3 months ago
Am i the only one getting exceptions on the EstimateShippingProductPageEnabled feature for logged in users when im on an old database? Ive tried 2 different webshops upgraded to 4.4, and for both webshops i get an error because the user has no shippingaddressId, which causes this query to fail:

Some of the callstack:
PrepareProductDetailsModelAsync
PrepareEstimateShippingModelAsync
GetCustomerShippingAddressAsync
GetCustomerAddressAsync
await _staticCacheManager.GetAsync(key, async () => await query.SingleAsync());

query.SingleAsync when there is no addresses causes an exception.
3 months ago
we were unable to reproduce the problem under normal use without interfering with the database, since the only way to get this problem is data inconsistency, namely when the ShippingAddress_Id field contains an identifier for a nonexistent record in the address table (usually this is impossible due to restrictions imposed by the rule of FK_Customer_ShippingAddress_Id_Address_Id foreign key). However, we decided to change the behavior of the GetCustomerAddressAsync method to prevent an error in this situation.

hkbits wrote:
Am i the only one getting exceptions on the EstimateShippingProductPageEnabled feature for logged in users when im on an old database? Ive tried 2 different webshops upgraded to 4.4, and for both webshops i get an error because the user has no shippingaddressId, which causes this query to fail:

Some of the callstack:
PrepareProductDetailsModelAsync
PrepareEstimateShippingModelAsync
GetCustomerShippingAddressAsync
GetCustomerAddressAsync
await _staticCacheManager.GetAsync(key, async () => await query.SingleAsync());

query.SingleAsync when there is no addresses causes an exception.
3 months ago
Sergei-k wrote:
we were unable to reproduce the problem under normal use without interfering with the database, since the only way to get this problem is data inconsistency, namely when the ShippingAddress_Id field contains an identifier for a nonexistent record in the address table (usually this is impossible due to restrictions imposed by the rule of FK_Customer_ShippingAddress_Id_Address_Id foreign key). However, we decided to change the behavior of the GetCustomerAddressAsync method to prevent an error in this situation.

Am i the only one getting exceptions on the EstimateShippingProductPageEnabled feature for logged in users when im on an old database? Ive tried 2 different webshops upgraded to 4.4, and for both webshops i get an error because the user has no shippingaddressId, which causes this query to fail:

Some of the callstack:
PrepareProductDetailsModelAsync
PrepareEstimateShippingModelAsync
GetCustomerShippingAddressAsync
GetCustomerAddressAsync
await _staticCacheManager.GetAsync(key, async () => await query.SingleAsync());

query.SingleAsync when there is no addresses causes an exception.


Perfect Sergey! Thanks!
3 months ago
In admin product page was Preview removed purposefully? Noticed it's not there in your demo site.
3 months ago
groundzero2010 wrote:
In admin product page was Preview removed purposefully? Noticed it's not there in your demo site.


I just realized this may be due to the fact the frontend and admin in the demo aren't tied together. Preview was probably removed for that  reason.
2 months ago
When I compile I get some Gulp message:

Failed to run "C:\Users\dootc\Documents\Visual Studio 2019\Websites\nopCommerce_4.40_Source\Presentation\Nop.Web\Gulpfile.js"...
cmd.exe /c gulp --tasks-simple
'gulp' is not recognized as an internal or external command,
operable program or batch file.



is this anything to be worried about?
2 months ago
Do you have node/npm? If not, get node and npm.

IF you have npm try this in cmd
npm i gulp -g
2 months ago
nopCommerce Team, It's incredible, I upgrade nopcommerce to the latest version and now I can't use discounts on the product. Before publishing a new version please make a better test or more paid for your bugs.
2 months ago
hkbits wrote:
Do you have node/npm? If not, get node and npm.

IF you have npm try this in cmd
npm i gulp -g


Thanks, I worked through it and that message went away.

Any short description of what that even is?
2 months ago
dootchie wrote:

Thanks, I worked through it and that message went away.

Any short description of what that even is?


What worked? Did u have to install node\npm, or just gulp?