Facebook external Authentication plugin is not working for Linux environment

Hace 6 meses
Hello guys,

We are facing a problem regarding the Facebook external Authentication plugin (the official plugin that the nop team developed).

The plugin is not working when you have nopCommerce on a Linux and nginx server environment.

The redirect uri always showing as http instead of showing as Https, which causes the authentication process to fail.

We tried all the configurations shown in the nopCommerce documentation regarding SSL troubleshooting.

Tried many tutorials exist on Microsoft docs regarding an asp.net application works on Linux and nginx server environment.

But all in vain, the redirect uri always got generated as http.

Anyone have an idea? Thank you!
Hace 5 meses
Hi, I have the same configuration (nginx reverse proxy) and the same problem with the External Auth plugin from sangeetshah
I will investigate.
I you find a solution I will be glad to hear from you.
Hace 5 meses
What we did was , we did all the configuration that exists in the nopCommerce documentation that related to SSL settings.
Then we added a piece of code that is explained in this tutorial of Microsoft here


And lastly disable the settings in the store configuration of enable SSL.

Maybe this could help
Hace 5 meses
Hi Starry,
Thanks for your advice. Adding this piece of code and disabling SSL option in the store remove the Facebook error. I am now able to connect with Facebook.
But now I have another issue. The browser is complaining of some images not secured.
Did you faced the same issue ?
Hace 5 meses
Have you added what nopCommerce documentation for troubleshooting ssl in nopCommerce said as well? There are some configuration you have to add to the appseeting.json file
Hace 5 meses
Yes I think I did everything but still no way.
If I put the piece of code and disable SSL Enabled  I get external authentication working and mixed content (due to product pictures not in relative path)
And If I remove the piece of code and enable SSL Enabled I don't have external authentication working but it removes mixed content warning .
I will investigate how to put images src with relative path
Hace 5 meses
Hmm, have you tried to force traffic to https in your default file (nginx server configuration),

And try to delete the cache and open from different private browser, we had the same problems, but your problem should be in those locations.

Good luck 🤞