"Has one product" discount requirement rule

"Has one product" discount requirement rule
3.0 2
This plugin allows to enable "Has one product" discount requirement rule in your store.
2021-10-24T14:14:22.0698495Z
Gratis
Obtener extensión (1419 Descargas)
Versiones soportadas: 4.00, 4.10, 4.20, 4.30
Creado: noviembre 29,2017
Última actualización: octubre 01,2020
Descripción

This plugin allows you to configure discounts for customers who have at least one of the specified products in the cart.

Discount requirement rule is a logical dependency in nopCommerce discount module that defines whether a discount applies or not, according to its conditions.

Installation instructions:

  1. Download the plugin archive.
  2. Go to admin area > configuration > local plugins.
  3. Upload the plugin archive using the "Upload plugin or theme" plugin.
  4. Scroll down through the list of plugins to find the newly installed plugin. And click on the "Install" button to install the plugin.

Please find more informartion about how to install plugins here.

Source code:

The plugin is provided absolutely for free and includes source code. Find the project Github repository here.

Reseñas
Don Pisotón 30/09/2020 16:13
Error with 4.3 version
It throws me an error when I try to install the plugin in nopCommerce 4.3 version.
Steps:
1- 'DiscountRules.HasOneProduct' contains binaries. Just drop it into \Plugins directory
2- Run the proyect with IIS Express

Text error:
System.Exception: 'Plugin 'Customer has one of these products in the cart'. Could not load file or assembly 'Nop.Services, Version=4.4.0.0, Culture=neutral, PublicKeyToken=null'. El sistema no puede encontrar el archivo especificado.
Could not load file or assembly 'Nop.Web.Framework, Version=4.4.0.0, Culture=neutral, PublicKeyToken=null'. El sistema no puede encontrar el archivo especificado.
Could not load file or assembly 'Nop.Services, Version=4.4.0.0, Culture=neutral, PublicKeyToken=null'. El sistema no puede encontrar el archivo especificado.
Could not load file or assembly 'Nop.Web.Framework, Version=4.4.0.0, Culture=neutral, PublicKeyToken=null'. El sistema no puede encontrar el archivo especificado.
¿Fue útil esta reseña? 0 / No0
wooncherk 12/10/2018 5:16
Work as expected.
Work as expected.
¿Fue útil esta reseña? 0 / No0