Upgrade 4.2 to 4.5

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.
2 anni tempo fa
Hi
Is upgrade like this:

Run SQL upgrade script for 4.3 and then run 4.5?
or how about 4.4 DB updates?
BR
TCH
2 anni tempo fa
TCH wrote:
Hi
Is upgrade like this:

Run SQL upgrade script for 4.3 and then run 4.5?
or how about 4.4 DB updates?
BR
TCH

please check this doc. may be helpful for you
https://docs.nopcommerce.com/en/installation-and-upgrading/upgrading-nopcommerce.html
2 anni tempo fa
Since version 4.40 nopCommerce don't use SQL upgrade scripts anymore. The upgrade is performed automatically with migrations (during the first application start). So when you upgrade from 4.30 to 4.40 you need to skip step 2 from the list below!
2 anni tempo fa
Yes I know the scripts not are used anymore.
My concern are do I need to take care of any updates related to 4.40 or are they included in 4.50, as I´m skipping version 4.40?

So in future updates from eg. 4.40 to 4.90 you only install 4.90 and that´s it. It will cover all the steps from 4.5 to 4.9?
2 anni tempo fa
Steps:
1. Make a backup of everything on your site, including the database. This is extremely important so that you can roll back to a running site no matter what happens during migration.
2. Remove all files from the previous version except JSON files in the 'App_Data' directory (dataSettings.json, plugins.json, appsettings.json), move them to the safe place.
3. Upload new site files
4. Copy back JSON files in the 'App_Data' directory.
5. Ensure that everything is OK

You have to  download .NET 6 SDK and ASP.NET Core Runtime 6.0.0 for other
operating systems (e.g. Linux, macOS, Windows). Because  nopCommerce 4.50 is supported to .NET 6


nopCommerce Release notes:
If you're upgrading nopCommerce to version 4.50 from one of the previous versions, please
ensure that your connection string contains one of the following parameters: "Encrypt=false" or
"TrustServerCertificate=True" (depending on your server requirements). You can manually add
these parameters to your connection string in the \App_Data\appsettings.json file. This step is
caused by the "Microsoft.Data.SqlClient" library that changed the default value of the "Encrypt"
option from "false" to "true".
2 anni tempo fa
Yes but I think the question is - do you need to load up v4.4 to do the upgrade from v4.3 to v4.4 first before loading up v4.5 to upgrade v4.4 to v4.5.
Or will v4.5 update everything straight from v4.3 to v4.5 ?
2 anni tempo fa
Yidna wrote:
Yes but I think the question is - do you need to load up v4.4 to do the upgrade from v4.3 to v4.4 first before loading up v4.5 to upgrade v4.4 to v4.5.
Or will v4.5 update everything straight from v4.3 to v4.5 ?

Excactly what I try to get answered :-)
I have done hundreds of upgrades in "old way" with SQL scripts and know this :-)
2 anni tempo fa
I have testet to upgrade from 4.30  to 4.50 BETA directly without install 4.40 first, this seems to work.
I had some problems with cache so it seems not to work the first couple of tries to refresh page.
2 anni tempo fa
Can someone from nop team please confirm this that once on a major version for example 4.40 we can jump directly to any minor version? for example 4.40 to 4.40.5

If this is not possible then it's crazy since for all minor upgrades we need to copy all the files at each minor upgrade.
2 anni tempo fa
Can we also have a statement from the nopcommerce team whether plugins from nop 4.0 to 4.4 will work with nop 4.5?

Plugins prior to nop 4.4 are built using .net 5 and nop 4.5 is built with .net 6.0, backward compatibility is not guaranteed.

This list below doesn't give me much confidence and I'll probably hold off any upgrades until all plugin  vendors catch up to nop 4.5.

https://docs.microsoft.com/en-us/dotnet/core/compatibility/6.0
This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.