Issue Upgrading from 4.40 to 4.50

9 mesi tempo fa
I have followed  the upgrade instructions included with the 4.50 version but cannot bring my site back online.

In the nginx error.log I see the following:
2022/02/21 15:25:40 [error] 3299#3299: *7152 connect() failed (111: Connection refused) while connecting to upstream, client: 114.119.136.24, server: promedicaldistribution.com, request:

I am also getting the following when I do a journalctl -xe:

Feb 21 15:39:41 ip-172-26-6-242 nopCommerce440-example[9030]: info: Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker[3]
Feb 21 15:39:41 ip-172-26-6-242 nopCommerce440-example[9030]:       Route matched with {action = "Manufacturer", controller = "Catalog", area = ""}. Executing controller action with signature System.Threading.Tasks.Task`1[Microsoft.AspNetCore.Mvc.>
Feb 21 15:39:41 ip-172-26-6-242 nopCommerce440-example[9030]: info: Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker[3]
Feb 21 15:39:41 ip-172-26-6-242 nopCommerce440-example[9030]:       Authorization failed for the request at filter 'Nop.Web.Framework.Mvc.Filters.HttpsRequirementAttribute+HttpsRequirementFilter'.

This site was functioning just fine prior to the 4.50 upgrade. It is a production site and I need to get it back online.

Can someone help me?
9 mesi tempo fa
erikfritzler wrote:

Feb 21 15:39:41 ip-172-26-6-242 nopCommerce440-example[9030]: info: Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker[3]

I dont know why this says nopCommerce440 when you are running v4.5
Did you copy v4.5 over v4.4 in the same directory
- if so ? that may cause issues - I always start with a fresh directory and do a new install
- then once it is running change the settings to point to your old database