nopCommerce 4.50 -Suggestions, bug reports and improvements

4 meses atrás
I was debugging the same thing in my plugin
I think the problem is in GetMigrations in
nopCommerce_4.50.0_Source\src\Libraries\Nop.Data\Migrations\MigrationManager.cs
It uses the version to check if the Migration has been applied
The record exists from when the pluign was installed - so test fails and assembly is not returned
4 meses atrás
Hi, Boyko! I created this issue and will check the problem

Nop-Templates.com wrote:
Hi guys,

It seems like when uninstalling a plugin with a database table the table is not deleted (Down migrations are not called).
You can easily test this with the Avalara plugin for example. After we uninstall the plugin the TaxTransactionLog table is still present.

Thanks,
Boyko
4 meses atrás
I fixed the problem with finding migrations to delete data, please see this commit to more details

Sergei-k wrote:
Hi, Boyko! I created this issue and will check the problem

Hi guys,

It seems like when uninstalling a plugin with a database table the table is not deleted (Down migrations are not called).
You can easily test this with the Avalara plugin for example. After we uninstall the plugin the TaxTransactionLog table is still present.

Thanks,
Boyko
4 meses atrás
Hi Support,

We have hosted our two sites on the server but suddenly it stopped working and the blank page comming. After a few minutes, its auto started. We don't track this issue. We have removed all plugins but it still it'continues to happening.  Could you please guide us?
We have used 4.5 nopcommerce version on our server.



Thanks,
Maulik
4 meses atrás
Sergei-k wrote:
I fixed the problem with finding migrations to delete data, please see this commit to more details


Hi Sergei,

Thank you for providing the fix so quickly!

I already noticed you have released a new minor version 4.5.1 with the fix.

Great job as usual!

Thanks,
Boyko
1 mês atrás
I have the same error on nopCommerce version 4.50.2 clean instalation.

Error on admin. the manus are stuck. I have to relode the page to make them work.



Failed to load resource: the server responded with a status of 500 (Internal Server Error)
HomeIndex.Footer.scripts.js:1          Failed to load resource: the server responded with a status of 500 (Internal Server Error)
kendo.messages.sv-SE.js:464 Uncaught TypeError: Cannot read properties of undefined (reading 'jQuery')
    at kendo.messages.sv-SE.js:464:17
    at kendo.messages.sv-SE.js:21:9
    at kendo.messages.sv-SE.js:23:3
Admin:3214 Uncaught ReferenceError: Globalize is not defined
    at Admin:3214:17
Admin:3220 Uncaught ReferenceError: kendo is not defined
    at Admin:3220:9


Uncaught TypeError: $(...).DataTable is not a function
    at HTMLDocument.<anonymous> (Admin:2350:41)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught TypeError: $(...).DataTable is not a function
    at HTMLDocument.<anonymous> (Admin:2512:44)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught TypeError: $(...).DataTable is not a function
    at HTMLDocument.<anonymous> (Admin:2643:27)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught TypeError: $(...).DataTable is not a function
    at HTMLDocument.<anonymous> (Admin:2820:39)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught TypeError: $(...).DataTable is not a function
    at HTMLDocument.<anonymous> (Admin:2930:43)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught TypeError: $(...).DataTable is not a function
    at HTMLDocument.<anonymous> (Admin:3068:41)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught ReferenceError: Admin is not defined
    at HTMLDocument.<anonymous> (Admin:3233:33)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2 Uncaught TypeError: $(...).backTop is not a function
    at HTMLDocument.<anonymous> (Admin:3251:27)
    at e (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30005)
    at t (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:30307)
Admin:2181 Uncaught ReferenceError: Chart is not defined
    at Object.success (Admin:2181:54)
    at c (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:28294)
    at Object.fireWith [as resolveWith] (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:29039)
    at l (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:79800)
    at XMLHttpRequest.<anonymous> (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:82254)
Admin:2313 Uncaught ReferenceError: Chart is not defined
    at Object.success (Admin:2313:57)
    at c (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:28294)
    at Object.fireWith [as resolveWith] (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:29039)
    at l (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:79800)
    at XMLHttpRequest.<anonymous> (jquery.min.js?v=fRy05QgwuHOHgsf6B2UWIyXdlUo:2:82254)
1 mês atrás
Find the problem!

File: appsettings.json

wrong path for the cash "CrawlerOnlyUserAgentStringsPath"

Now it is working with  ""~/App_Data/browscap.crawlersonly.xml" :)


"CommonConfig": {
    "DisplayFullErrorStack": false,
    "UserAgentStringsPath": "~/App_Data/browscap.xml",
    "CrawlerOnlyUserAgentStringsPath": "~/App_Data/browscap.crawlersonly.xml",
    "UseSessionStateTempDataProvider": false,
    "MiniProfilerEnabled": false,
    "ScheduleTaskRunTimeout": null,
    "StaticFilesCacheControl": "public,max-age=31536000",
    "SupportPreviousNopcommerceVersions": true,
    "PluginStaticFileExtensionsBlacklist": ""
  }
1 mês atrás
Stergios wrote:
wrong path for the cash "CrawlerOnlyUserAgentStringsPath"

What exactly is wrong? Please clarify
1 mês atrás
Hi!

When i compiled the project in vs the it was wrong path to this file "appsettings.json", when i put it on the live server the admin dient work properly:

The url was c://local/nopcomerce/App_Data..

i change it to "~/App_Data/browscap.crawlersonly.xm"

Regards,
Stergios
4 semanas atrás
We are having the same issue on first page load. The css and js files are not loaded, once you refresh the page everything works fine.
The error is the following: "Access to the path 'XXXXX\wwwroot\bundles' is denied." but it has access to this folder.
Can someone please let me know what is the solution to this?