Getting started. Installing and upgrading nopCommerce.

один год назад
i upgrading from 4.2 to 4.3 and get this error in sql
https://ishraqst.com/
can u help me with this ?
один год назад
Hi all,

Please could somebody help? I am upgrading from v4.0 to v4.3, I have tried problem solving by upgrading one version at a time. I find that all works well on all versions , however I notice a change only when going from v4.2 to v4.3, this change is that the "Low Stock" report shows thousands of product entries, some of which belong to deleted products and have sufficient stock. I have checked in the Database, these entries do exist and are related to the "Product Attribute Combination" inventory management.  I have tried recreating products and their attributes but same error happens when I create "Product combinations" - those will then show in Low Stock report regardless of the stock quantity. If I try manage the stock on basic inventory management(of the newly created product) it responds correctly. Any idea's? Thanks.
один год назад
Hello Community.
i have the following connection string problem:
What is wrong with my c-String 430
{
  "DataProvider": "sqlserver",
  "DataConnectionString": "Data Source=localhost;Initial Catalog=myDB;Integrated Security=False;Persist Security Info=False;User ID=xxx_dbuser;Password=password",
  "RawDataSettings": {}
}


An error occurred while starting the application.
ArgumentException: Keyword not supported: 'initial
catalog'.
System.Data.Common.DbConnectionOptions.ParseInternal(Dictionary<string, string> parsetable, string connectionString, bool buildChain, Dictionary<string, string> synonyms, bool firstKey)

DependencyResolutionException: An exception was thrown while activating λ:Nop.Core.Domain.Common.CommonSettings -> Nop.Data.Migrations.MigrationManager -> λ:FluentMigrator.Runner.IVersionLoader.
Autofac.Core.Resolving.InstanceLookup.Activate(IEnumerable<Parameter> parameters, out object decoratorTarget)

ArgumentException: Keyword not supported: 'initial catalog'.
System.Data.Common.DbConnectionOptions.ParseInternal(Dictionary<string, string> parsetable, string connectionString, bool buildChain, Dictionary<string, string> synonyms, bool firstKey)
System.Data.Common.DbConnectionOptions..ctor(string connectionString, Dictionary<string, string> synonyms)
System.Data.SqlClient.SqlConnectionString..ctor(string connectionString)
System.Data.SqlClient.SqlConnectionFactory.CreateConnectionOptions(string connectionString, DbConnectionOptions previous)
System.Data.ProviderBase.DbConnectionFactory.GetConnectionPoolGroup(DbConnectionPoolKey key, DbConnectionPoolGroupOptions poolOptions, ref DbConnectionOptions userConnectionOptions)
System.Data.SqlClient.SqlConnection.ConnectionString_Set(DbConnectionPoolKey key)
System.Data.SqlClient.SqlConnection.set_ConnectionString(string value)
FluentMigrator.Runner.Processors.GenericProcessorBase+<>c__DisplayClass6_1.<.ctor>b__1()
System.Lazy<T>.ViaFactory(LazyThreadSafetyMode mode)
System.Lazy<T>.CreateValue()
System.Lazy<T>.get_Value()
FluentMigrator.Runner.Processors.GenericProcessorBase.get_Connection()
FluentMigrator.Runner.Processors.GenericProcessorBase.EnsureConnectionIsOpen()
FluentMigrator.Runner.Processors.GenericProcessorBase.BeginTransaction()
FluentMigrator.Runner.Processors.SqlServer.SqlServerProcessor.BeginTransaction()
FluentMigrator.Runner.TransactionalMigrationScope..ctor(IMigrationProcessor processor, Action disposalAction)
FluentMigrator.Runner.MigrationScopeHandler.BeginScope()
FluentMigrator.Runner.MigrationScopeHandler.CreateOrWrapMigrationScope(bool transactional)
FluentMigrator.Runner.MigrationRunner.ApplyMigrationUp(IMigrationInfo migrationInfo, bool useTransaction)
FluentMigrator.Runner.MigrationRunner.Up(IMigration migration)
FluentMigrator.Runner.VersionLoader.LoadVersionInfo()
FluentMigrator.Runner.VersionLoader..ctor(IProcessorAccessor processorAccessor, IConventionSet conventionSet, IMigrationRunnerConventions conventions, IVersionTableMetaData versionTableMetaData, IMigrationRunner runner)
Microsoft.Extensions.DependencyInjection.ActivatorUtilities+ConstructorMatcher.CreateInstance(IServiceProvider provider)
Microsoft.Extensions.DependencyInjection.ActivatorUtilities.CreateInstance(IServiceProvider provider, Type instanceType, object[] parameters)
Microsoft.Extensions.DependencyInjection.ActivatorUtilities.CreateInstance<T>(IServiceProvider provider, object[] parameters)
Microsoft.Extensions.DependencyInjection.FluentMigratorServiceCollectionExtensions+<>c.<AddFluentMigratorCore>b__0_6(IServiceProvider sp)
Autofac.Extensions.DependencyInjection.AutofacRegistration+<>c__DisplayClass3_0.<Register>b__0(IComponentContext context, IEnumerable<Parameter> parameters)
Autofac.Core.Activators.Delegate.DelegateActivator.ActivateInstance(IComponentContext context, IEnumerable<Parameter> parameters)
Autofac.Core.Resolving.InstanceLookup.Activate(IEnumerable<Parameter> parameters, out object decoratorTarget)
один год назад
I checked and saved the following two options:
-JavaScript bundling and minification  
-CSS bundling and minification  
If I uncheck it, it will return to the previous state. No problem for the website?
один год назад
Hola, has encontrado solución? Poca gente de habla hispana en este foro. Cuéntame por favor si has podido instalar y poner a funcionar el nopComerce y si has encotrado algúbn experto que pueda ayudarte.
Necesito a alguien free lance, que lo instale por mi, para montar una market place, para enfocarlo a un mercado específico, inicialmente en Medellín, Colombia, y que nos haga acompañamiento a menos durante un tiempo, ojalá haciéndose cargo de mantenimiento y desarrollo de la plataforma.
  
Deberá capacitarnos para vincular y mantener clientes, que son los dueños de tiendas físicas a quienes vamos a ofrecer esta plataforma como una vitrina adicional y portal de ventas para sus negocios, y en el tema de gestión de la tienda, para poder hacer demostraciones  potenciales clientes, en plan de vincularlos al market place. Después en el tema de montar una nueva tienda virtual para ventas de una tienda física, todo ello con miras al servicio al cliente.  

Mientras nos capacitamos,  nuestro Free Lance tendrá a su cargo el montaje de cada tienda que vinculemos o, por  lo menos, dirigir el montaje, entendido que nos encargaremos de suministrarle los insumos de data necesarios.

Así que si consideras que algo de tu experiencia puede servirnos, te agradezco que me compartas lo que  te parezca compartible.
один год назад
@Eneanito
Please don't duplicate topics.  In your case it would have been best to just post one new topic with your requirements in the "Commercial help wanted" forum.
один год назад
Hi All,

I am trying to install 4.3.0 to Azure with CI/CD configured to GITHUB repo.

I get below error after the successful deployment from GITHUB..
FileNotFoundException: Could not load file or assembly 'Avalara.AvaTax.netstandard11, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified

Below are the steps which can reproduce the issue.
1-> Downloaded the source code from nopcommerce site
2-> added to GITHUB repo
3-> Created a new APP Service in Azure
4-> Configured CI/CD from Azure->deployment center to point to GITHUB Repo.. choosed .NET CORE 3.1 as technology stack
5-> Pushed the code to GITHUB Repo from my local GIT
6-> Deployment workflow initiated at GITHUB
7-> Deployment successful
8-> and we get this error..


To be sure... I then published directly to AZURE.. using VS .. the same source code.. and It worked without any issue..

This issue is only when using the VS->GITHUB->CI/CD->AZURE...

Any help is appreciated.
9 месяцев назад
Hi all,

I just downloaded 4.4, installed the .NET Core 5 requirements, and opened it up in VS2019. When I try to run it, I see all kinds of dependencies missing but I am also getting many messages like this:

Severity  Code  Description  Project  File  Line  Suppression State
Error  MSB4018  The "ResolvePackageDependencies" task failed unexpectedly.
System.ArgumentException: Could not find TargetFramework alias in lock file for .NETFramework,Version=v5.0
   at Microsoft.NET.Build.Tasks.LockFileExtensions.GetLockFileTargetAlias(LockFile lockFile, LockFileTarget lockFileTarget)
   at Microsoft.NET.Build.Tasks.ResolvePackageDependencies.<ExecuteCore>b__46_1(LockFileTarget t)
   at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)
   at Microsoft.NET.Build.Tasks.ResolvePackageDependencies.ExecuteCore()
   at Microsoft.NET.Build.Tasks.TaskBase.Execute()
   at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
   at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__26.MoveNext()  Nop.Plugin.DiscountRules.CustomerRoles  C:\Program Files\dotnet\sdk\5.0.302\Sdks\Microsoft.NET.Sdk\targets\Microsoft.PackageDependencyResolution.targets  186  


I really would like to know khow to get this resolved and why the dependencies are missing? The dependencies are in the NopCore Packages (all of them missing)

TIA
Jon
5 месяцев назад
I can't set it up locally.
I followed the instruction for Version 4.40.4
Im on Mac M1 Pro
1) I was downloaded "nopCommerce_4.40.4_Source.zip"
2) running Docker SQL Server image ready
3) sql studio created a new database by "CREATE DATABASE nopTest;"
4) use visual studio 2022/ and visual studio 2019 both tested. open the file NopCommerce.sln by visual studio.
5) after the package restored and ready select Chrome and click run
6) It pops up the install window.
7) server name is localhost , user name sa it seems the configuration is correct.
8) after I click install the loading is forever , it seems stuck there and visual studio console trow exceptions as below.
it seems go throw the database , and load lots of the tables, I'm assume the database loading is fine, but it won't redirect me to the store page.


-------------------------------------------------------------------
Order(RewardPointsHistoryEntryId) RewardPointsHistory(Id)
FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor: Information: ALTER TABLE [dbo].[Order] ADD CONSTRAINT [FK_Order_RewardPointsHistoryEntryId_RewardPointsHistory_Id] FOREIGN KEY ([RewardPointsHistoryEntryId]) REFERENCES [dbo].[RewardPointsHistory] ([Id])
info: FluentMigrator.Runner.MigrationRunner[1000]
FluentMigrator.Runner.MigrationRunner: Information: => 0.002798s
FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor: Information: INSERT INTO [dbo].[MigrationVersionInfo] ([Version], [AppliedOn], [Description]) VALUES (637200411689037680, '2021-12-18T04:32:00', N'AddOrderRewardPointsHistoryFK')
FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor: Information: Committing Transaction
FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor: Information: COMMIT TRANSACTION
FluentMigrator.Runner.MigrationRunner: Information: 637200411689037680: AddOrderRewardPointsHistoryFK migrated
FluentMigrator.Runner.MigrationRunner: Information: => 0.008494s
info: FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor[1003]
      ALTER TABLE [dbo].[Order] ADD CONSTRAINT [FK_Order_RewardPointsHistoryEntryId_RewardPointsHistory_Id] FOREIGN KEY ([RewardPointsHistoryEntryId]) REFERENCES [dbo].[RewardPointsHistory] ([Id])
info: FluentMigrator.Runner.MigrationRunner[1002]
      => 0.002798s
info: FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor[1003]
      INSERT INTO [dbo].[MigrationVersionInfo] ([Version], [AppliedOn], [Description]) VALUES (637200411689037680, '2021-12-18T04:32:00', N'AddOrderRewardPointsHistoryFK')
info: FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor[1004]
      Committing Transaction
info: FluentMigrator.Runner.Processors.SqlServer.SqlServer2016Processor[1003]
      COMMIT TRANSACTION
info: FluentMigrator.Runner.MigrationRunner[1004]
      637200411689037680: AddOrderRewardPointsHistoryFK migrated
info: FluentMigrator.Runner.MigrationRunner[1002]
      => 0.008494s
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
Loaded '/Users/shuang/Projects/Dotnet/local-commerce/nopCommerce_4/Presentation/Nop.Web/bin/Debug/net5.0/System.Linq.Async.dll'.
Exception thrown: 'System.Reflection.ReflectionTypeLoadException' in System.Private.CoreLib.dll
5 месяцев назад
thanks ahead
please help me set it up I really need it to work on my new Mac.