ERR_TOO_MANY_REDIRECTS

3 年 前
Hi,

I've installed a SSL-certificate (bought via hoster and auto-installed).
After the certificate was installed I checked for force ssl and Use SSL in config/shops. But after this config was saved I can't open the sites pages - I get the error message "ERR_TOO_MANY_REDIRECTS".

How do I get into the store again?
What to change?
3 年 前
Hello,

Did you enable SSL here: http://admin-demo.nopcommerce.com/Admin/Store/Edit/1
and did you added url with https in Secure URL  ?

If so then restart the site then check after few minutes.

Thanks,
Jatin
3 年 前
Enabled ssl in administration/Configuration/Stores and also checked for force ssl.

The web-site is running on a hosted solution, so I can't restart any on my own.
3 年 前
...and yes - that's where you linked to :-)
3 年 前
Hello,

Can you check somewhere did you added any redirect code for to www or to https in hosting provider or web.config ?

Thanks,
Jatin
3 年 前
Just added https://yourstore.com in the field for Secure URL. (but replaced with my url of course)
3 年 前
The exact error in my browser:
"Details
There were too many redirections.
Error Code: INET_E_REDIRECT_FAILED"
3 年 前
Do we have URL of your site ?
3 年 前
sagmyra.no
3 年 前
In web.config I found some settings commented:
<!--  Uncomment one of the settings below if your hosting uses a load balancer. It'll be used to determine whether the current request is HTTPS.-->
    <!--<add key="Use_HTTP_CLUSTER_HTTPS" value="true" />-->
    <!--<add key="Use_HTTP_X_FORWARDED_PROTO" value="true" />-->
    <!-- Uncomment the setting below if your hosting doesn't use "X-FORWARDED-FOR" header to determine IP address.
    In some cases server use other HTTP header. You can specify a custom HTTP header here. For example, CF-Connecting-IP, X-FORWARDED-PROTO, etc-->
    <!--<add key="ForwardedHTTPheader" value="CF-Connecting-IP" /> -->

Mey the error message "There were too many redirections.
Error Code: INET_E_REDIRECT_FAILED" relate to one of these web.config settings?