HTTP Error 500.32 - ANCM Failed to Load dll

3 个月 前
Hello guys,

I am facing "HTTP Error 500.32 - ANCM Failed to Load dll" error while trying to install nopcommerce on my server. I have Windows server 2012 R2 and IIS 8.5.
I already installed .net core 3.1 as instructed on nopcommerce pre-requisite.

please see this image for more info.
3 个月 前
Are you tryning to install 4.30?  Is it the current release, or an old/beta ?
https://www.nopcommerce.com/en/boards/topic/80146/nopcommerce-430-beta-released-please-share-your-impressions/page/8#262619
3 个月 前
Yes i am trying fresh installation with nopcommerce 4.3   NoSource.
3 个月 前
Hi,

I have also got this issue when i was first upload my nopcommerce website on shared hosting i am able get it work by changing modules="AspNetCoreModuleV2" to modules="AspNetCoreModule" in web config.

Just change AspNetCoreModule to AspNetCoreModuleV2 or if have AspNetCoreModuleV2 just change it to AspNetCoreModule it will work.
3 个月 前
I have also got this issue when i was first upload my nopcommerce website on shared hosting i am able get it work by changing modules="AspNetCoreModuleV2" to modules="AspNetCoreModule" in web config.

Just change AspNetCoreModule to AspNetCoreModuleV2 or if have AspNetCoreModuleV2 just change it to AspNetCoreModule it will work.

I tried this too. but no luck...
3 个月 前
Solved,

Added different Application Pool and set that pool as Application pool.
In new Application pool set "Enable 32-bit application" to True.
1 个月 前
Hi All, I have the same Problem, I used the automation to install this nopcommerce webshop directly on my azure subscription, I followed the install instructions on your webpage and ended with: up all running, without any issues.
But when I open the Webpage, it doesn't work, with the same error as above. But how can I edit files from an azure service? I'll tried to use the console from the App Service where the installation takes place, but to be honest, I'm totally lost at this place.

Thank you for any advice, how I can fix it would be really appreciated.
1 个月 前
It's me again, in the meantime i figured out how to manipulate the web.config file and save it. In this case I changed from v2 to without v2, after saving, the website told me another error. so I changed it back to v2 and get the first 500.32 ANCM Failed to Load dll again
1 个月 前
Yes, I used google for that, to figure the basic error. 😉
But I provisioned it on Azure from the Marketplace, in this Case I have no influence on the full provisioning at the backend, I guess there is an ARM template that build the server and the web apps in Azure.
So how can I change or troubleshoot this error?