Problem with running 4.3 - intermittent results

2 个月 前
Hi Guys
I have a new problem. I just installed a clean version of Nop 4.3 on my server (remote desktop), gave it a dedicated app pool (4.0), created the database and user, set all the permissions and then ran it. The Install page showed on Chrome that was being run on the server, so I ran the install and all worked fine. I then came back to my local computer and ran the store URL in Chrome and I got the IIS Splash screen. I then tried running it on Firefox and it loaded fine.

I kept clearing cache and cookies on my local Chrome but it still only shows the Windows IIS screen when I go to the URL. I then tried and incognito tab but still the IIS.

I have another website running 4.3 on the same server, so I checked it's settings in IIS managber and noted that it was still running .NET 4.0 with integrated pipeline, so I tried setting this new one to integrated pipeline instead and restarted it. This time it went to IIS splash screen in Chrome on the server (remote desktop) plus it still showed IIS screen on local Chrome, but firefox is still showing the NopCommerce home page and running the website correctly!

What is going on and how can I get it to run everywhere? Can somebody please help?

Cheers
2 个月 前
Re: .NET 4.0 with integrated pipeline,
It does not look at this setting - set it as "No Managed Code" for future refernece to note its not using .net 4.X

Given that you have another v4.3 website on the same server we can assume the server is setup

Are you getting any errors in the log - on the page ?

Do you have SSL enabled on this domain ?
Is the other site in the same domain using SSL and this site no SSL ?
Does the domain you are using have SSL subdomain anywhere ?
Chrome has issues with this sort of stuff
2 个月 前
Thanks for your reply Yidna!
Of course, I keep forgetting about the .core being stand alone. I changed it to No Managed Code.

You were right, there was no SSL certificate installed. I added one.

Ok, so now, on the server (remote desktop) Chrome, the page loaded and I managed to log into the admin area to assign it to SSL. It now loads fine there.

Back at my local computer trying to access the URL with https, both Firefox and Chrome now say:

Not Found
HTTP Error 404. The requested resource is not found.

I have cleared the cache on both browsers.

If I try and access it via http both still give me the IIS Splash Page.

Can I assume this is just a case of needing it to timeout and restart before I try again?

Also, just for reference, Nop was loading sometimes at the http URL on my phone, and then after a timeout it went back to IIS Splash, then after another timeout it would load again, ....and on and on just random results. Do you know why it would be doing this? It's almost as if it is not starting on the server and not a Chrome or Firefox browser issue.

Again, thanks so much for your help!
2 个月 前
...Yes, you know what happened. The hosting account was created and for some reason assigned the Bindings IP address to the server IP. I changed it to All Unassigned and guess what?

Ultimately though, it was your advice on the SSL and No Managed Code that saved the day. Again I thank you Yinda.