Unable to send out email nopCommerce version 4.30

3 个月 前
hello,

unable to send out email using the following settings.

NOP backend: configuration->email accounts

email address: [email protected]
email display name: Ampec Technologies Online Store
host: smtp.office365.com
port: 587
user: [email protected]
password:
SSL: unchecked
use default credentials: unchecked

when I send test email, i got error as shown below.
"×535: 5.7.3 Authentication unsuccessful [SYBPR01CA0139.ausprd01.prod.outlook.com]"

we tried google SMTP server: smtp.gmail.com and SSL port 465 and it was able to send out email however the problem is the recipient of the email would receive an from @gmail.com

anyone encounter the same issue? I have read lots of similar cases in this forum but nothing works for me. There is also a mentioned that this is an existing bug or limitation with version 4.30 and will be fixed in the next release?

thanks for the help!
3 个月 前
double check your email account in Microsoft 365 admin portal
3 个月 前
thanks for your reply JayC.

I already have checked this email account at 365 portal and can confirm that Authenticated SMTP is Enabled and multi-factor authentication is Disabled.

The details of 365 SMTP is as shown below as it does not support SSL port 465. How is this accomplished in nopcommerce as I cannot see STARTTLS encryption there that's why I did not enabled SSL checkbox?

Server: smtp.office365.com
Port: 587
Encryption: STARTTLS

thanks
3 个月 前
[email protected] wrote:

Server: smtp.office365.com
Port: 587
Encryption: STARTTLS
thanks


In nop, having SSL unchecked uses TLS. Your mail configuration is correct and there is nothing else you can do on the nopcommerce side.

It must be some setting or client access config on the office 365 portal that you need to  adjust. Unfortunately the error message is quite generic. I suggest doing a process of elimination by quickly setting up a dev nop environment in isolation on a seperate network to see if your emails can send from there with the same settings.
2 个月 前
Try to enable SMTP AUTH in your organization. This may be done ONLY via Exchange Online PowerShell. Here is the instruction.

https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/authenticated-client-smtp-submission#enable-smtp-auth-for-specific-mailboxes

This worked for me
2 个月 前
hello hayco, SMTP auth for this account is already enabled via 365 admin center.
when i tried to do your powershell, i got the below error. did i miss something?

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.
Try the new cross-platform PowerShell https://aka.ms/pscore6
PS H:\>
PS H:\> Set-CASMailbox -Identity [email protected] -SmtpClientAuthenticationDisabled $false
Set-CASMailbox : The term 'Set-CASMailbox' is not recognized as the name of a cmdlet, function, script file, or
operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
again.
At line:1 char:1
+ Set-CASMailbox -Identity [email protected] -SmtpClientAuthentic ...
+ ~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Set-CASMailbox:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
2 个月 前
my other question is that, I was already able to work with email out using google as the authentication credentials for SMTP however the problem is when the email is sent out, it is coming from @gmail.com instead of [email protected]
why it's like this? is this by design of nopcommerce?

nopcommerce settings:
email address: [email protected]
Email display name: Ampec Technologies Online Store
Host: smtp.gmail.com
Port: 465
User: <google account @gmail.com>
Password: <google account password>
SSL: checked
Use default credentials: <empty>

Thanks - Reynaldo
2 个月 前
we also tried to use the SMTP of our ISP which does not require any authentication and still failed and got error as shown below:

"An error occurred while attempting to establish an SSL or TLS connection. This usually means that the SSL certificate presented by the server is not trusted by the system for one or more of the following reasons: 1. The server is using a self-signed certificate which cannot be verified. 2. The local system is missing a Root or Intermediate certificate needed to verify the server's certificate. 3. A Certificate Authority CRL server for one or more of the certificates in the chain is temporarily unavailable. 4. The certificate presented by the server is expired or invalid. It is also possible that the set of SSL/TLS protocols supported by the client and server do not match. See https://github.com/jstedfast/MailKit/blob/master/FAQ.md#SslHandshakeException for possible solutions."

nopcommerce settings:
email address: [email protected]
Email display name: Ampec Technologies Online Store
Host: mail.tpg.com.au
Port: 25
User: <empty>
Password: <empty>
SSL: unchecked
Use default credentials: <empty>

is SMTP without authentication port 25 not supported by nopcommerce 4.30?


Thanks,
Reynaldo
2 个月 前
Your problem still ongoing? Does your infrastructure have a reverse proxy by any chance?

Maybe its time for you to setup a dev nop environment and try these email settings on a separated network.
2 个月 前
Hi JayC, yes the problem is still there.

we are isolating the issue at the moment.
1. we are going to add that 365 account we use in nop to an outlook client we have and see whether it can send out an email.

2. we are also going to install a local onprem mail server using hmailserver opensource and see whether we can use this local IP address as the SMTP server for nop.

question to you --- does nop support plain SMTP port 25 with authentication?
also does it support SMTP port 25 without authentication at all?

really appreciate your help.

regards
reynaldo