too much seconds for view home page

1 个月 前
hi everyone,
i have deployed my website into a remote hosting but I have a problem with the visualization: the  home page spends 30/40 second for to be view, after the webite is more quickly. If I browse on home page after 1 hour I wait again 30 second for view the page (and this is not good). I think the problem is the reset of application pool, when site have not visitor, that is setting at 20 minutes and I can't change it (I have ionos hosting).
my question: is there a workaround for keep up the application pool without visit on the site? a javascript every 15 minuters or other.
thank you for the answers.
nello
1 个月 前
Let me help you with few points.

1. Make sure keep alive task is running in nopcommerce schedule task. https://www.nopcommerce.com/en/boards/topic/51216/keep-alive
2. Do you have vps or shared hosting? if vps then go to iis and select your website app pool and right click and go advance setting to do some changes. Start mode should be always running and idle time out should be 0(zero).

Try and then see.

Thanks,
Jatin
1 个月 前
hi jatin
thank you for the answer
I have hosting and I found very intersting keep alive function. Unfortunately I have always enabled keep alive setting in sistem information => schedule tasks but after 20 minuts my website reset pool.
Why not work correcly? Can I view log or enable other functionality?

thank you
nello
1 个月 前
RE: "20 minuts my website reset pool"
How do you know that - are you looking at IIS log?
As per the link given above, you can check System > Log for any problems or app restarts, and you can manually hit the keepalive link and then 15 minutes later, hit your site home page to see how long it takes, and also check  check System > Log for restart message.
1 个月 前
hi
I have changed link store (it was localhost still) but the log give me an error:
The "Keep alive" scheduled task failed with the "One or more errors occurred. (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.)" error (Task type: "Nop.Services.Common.KeepAliveTask, Nop.Services". Store name: "DesiNet". Task run address: "http://www.desinet.it/scheduletask/runtask").
I have not ssl and I set link store in many type (with www, with https, ecc) but the error is always there.
What can I make to resolve?
thanks
nello
1 个月 前
Make sure the Store URL is correct (in Configuration -> Stores)
Try this including the http:// prefix, and the trailing /
  http://yourdomain.com/

(see this for related issues)
1 个月 前
nothing to do
I set the link store with http, without http, with www, with slash, ecc but the error is always the same.
one question: what should I see if I write http://www.desinet.it/scheduletask/runtask into the address bar inside the browser? Now I receive HTTP ERROR 405 the page doesn't work. it is normal?
thank for the answer
nello
1 个月 前
I think the runtask URL is supposed to end with the Id of the task to run - e.g.
.../Admin/ScheduleTask/RunNow/5

If you are just trying to access the keepalive, then the URL would be - e.g.
https://demo.nopcommerce.com/keepalive
1 个月 前
hi new york and thank you for the answer
the link mysite\keepalive aswers correctly "I am alive!" but the link
http://www.mysite.it/Admin/ScheduleTask/RunNow/2 answers this error:
One or more errors occurred. (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.)

I think this is a problem with my web hosting provider (ionos) .
if anyone has an idea I would appreciate
by
nello