'Invalid object name 'Store' after copying DB to Azure. Ok on localhost

1 个月 前
Hi
I upgraded from 4.0 to 4.3 (NopCommerce with Pavilion Theme)
My steps where:
1. Ran the 3 sql script 4.0 to 4.1. 4.1 to 4.2 & 4.2 to 4.3 OK.
2. Upgraded by VS2019 solution with NopCommerce 4.3
3. Solution upgraded and runs OK on localhost.
3. Tried exporting the database to bacpac file, but failed due to Nop Ajax filter encrypted scrips.
4. Acc. to forums, uninstalled the Nop Ajax filters and exported to bacpac OK
5. Copied the bacpac to Azure and installed the database.
6. Published the NopCommerce to AppService and ftp'd the datasettings and plugins json as on localhost.
7. Getting ERROR: Invalid Object name 'Store', line 337 in DependencyRegistrar.cs
8. Ran localhost with dataconnection to Azure. Getting the same error.

Cannot find out where the difference lies when connecting to localhost database vs. azure database. They should be identical.
1 个月 前
Did you look in the Azure Database to see if the Store table is in there?
1 个月 前
SOLVED:  It turned out to be Azure taking forever to update db roles.