Install NopCommerce en local Linux (Ubuntu) with Visual Studio Code

1 个月 前
I wanted to install NopCommerce on a local machine, which has Linux Ubuntu.
I installed Visual Studio Code and copied the Nopcommerce archive (with source code) in the Workspace. I changed the folder permissions of Nop.Web folder and below to full rights for all users. using chmod 777.
I am able to start the local server and get to the installation page. But I am stuck now, because Nopcommerce informs that the modifying permissions are not sufficient and doesnt install. I believe its a Linux problem, but I just cannot find any hint  of how to resolve this issue.

------
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/App_Data'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/bin'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/logs'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/Plugins'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/Plugins/bin'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/bundles'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/db_backups'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/files/exportimport'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/icons'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/images'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/images/thumbs'. Please configure these permissions.
The 'user-machine\user' account is not granted with Modify permission on folder '/home/user/Proyectos user/Visual Studio/nopCommerce_4.30/Presentation/Nop.Web/wwwroot/images/uploaded'. Please configure these permissions.
1 个月 前
You probably need the -R flag to chmod which makes it recursive, otherwise you will only set that one folder/file's permission and not the subfolders and files.
1 个月 前
Thank you for your answer. Yes i used -R recursive. The Folder Nop.Web and al folders below have full rights.
1 个月 前
I solved the problem, it is much simpler than thought. I had in the folder structure where my Workspace is located Folders with " " spaces in the name. This couldnt be handled by Linux.
** SOLVED **