Force SSL for site pages redirects everything to homepage?

один месяц назад
I have three sites with three separate IIS server instances running nopCommerce 4.10.

The domains look like this:
www.mysite.com
subdomain1.mysite.com
subdomain2.mysite.com

Under "Configuration > Stores" the Shop URLs each are set with https://  and the enable SSL box is checked.

Under "host values," the subdomain sites look like this:
subdomain1.mysite.com,mysite.com
subdomain2.mysite.com,mysite.com

Under the "host values" for the www site, it looks like this:
www.mysite.com,mysite.com

Under "Configuration > Settings > General settings > Security, "Force SSL for all site pages" is checked.

If I click on a product URL, it will look something like:  https://www.mysite.com/widgetA

If I type instead the same URL in my address bar with http instead of https, I would expect the "Force SSL" settings to redirect to https://www.mysite.com/widgetA.  But instead, it just redirects to the homepage.  This happens on all three sites.

What is going on here?  Why doesn't it redirect the full URL to https?
один месяц назад
tinacorr wrote:
Under "host values," the subdomain sites look like this:
subdomain1.mysite.com,mysite.com
subdomain2.mysite.com,mysite.com
Under the "host values" for the www site, it looks like this:
www.mysite.com,mysite.com


For starters the host values should not all have mysite.com
the main site can be
www.mysite.com,mysite.com

the others stoes should just be
subdomain1.mysite.com
and
subdomain2.mysite.com

Also stop and restart the webserver after the change to make sure

Try that and see what happens
один месяц назад
Yidna wrote:
For starters the host values should not all have mysite.com
the main site can be
www.mysite.com,mysite.com


Thanks for the suggestion!  I removed mysite.com from the two subdomains and restarted the applications.  Unfortunately the redirect issue persists.
один месяц назад
Hi,
Is there any URL rewriting on IIS level or at domain management system ?

tinacorr wrote:
I have three sites with three separate IIS server instances running nopCommerce 4.10.

The domains look like this:
www.mysite.com
subdomain1.mysite.com
subdomain2.mysite.com

Under "Configuration > Stores" the Shop URLs each are set with https://  and the enable SSL box is checked.

Under "host values," the subdomain sites look like this:
subdomain1.mysite.com,mysite.com
subdomain2.mysite.com,mysite.com

Under the "host values" for the www site, it looks like this:
www.mysite.com,mysite.com

Under "Configuration > Settings > General settings > Security, "Force SSL for all site pages" is checked.

If I click on a product URL, it will look something like:  https://www.mysite.com/widgetA

If I type instead the same URL in my address bar with http instead of https, I would expect the "Force SSL" settings to redirect to https://www.mysite.com/widgetA.  But instead, it just redirects to the homepage.  This happens on all three sites.

What is going on here?  Why doesn't it redirect the full URL to https?
один месяц назад
jigarsangoi wrote:
Hi,
Is there any URL rewriting on IIS level or at domain management system ?


Hi, no, there is no additional URL rewriting at the IIS level.