Running nopCommerce 4.3 without source code on IIS

один месяц назад
Hi, I am having some trouble with trying to run my site on IIS without the Source Code. I have followed the documentation but the steps are a little vague. Is there a step by step guide on how to do this? Thank you.
один месяц назад
Hello Nabilah Mazlan
Please go through with below link. there is lots of suggestions that you can find.
https://www.nopcommerce.com/en/boards/topic/82165/how-to-publish-and-deploy-in-iis-step-by-step
один месяц назад
Enable error log into webconfig and check log for issue .

or try below code into web.config to see the actual error
<aspNetCore .....>
      <environmentVariables>
        <environmentVariable name="ASPNETCORE_ENVIRONMENT" value="Development" />
      </environmentVariables>
    </aspNetCore>
один месяц назад
Hi Guys,
I'm an advocate of nopCommerce, but I haven't had the need to use it for a while.

I've recently installed two instances on separate web sites on my Plesk Obsidian server and when I load either site I get a 500 Internal Server Error.

I have changed the dedicated IIS Pool to classic and still get the same error.

I've noticed that hen I unzipped the distribution in the root directory, there were loads of .dll files and a wwwroot directory.

Is that normal?

Any ideas on the 500 error? Incidentally, there are no errors thrown in the console for me to go on.

Michael.
один месяц назад
To confirm you are installing v4.3 ?
Yes all those files in the root are correct - this is the .NetCore structure
Have you installed .NetCore 3.1 and done the other requirements
See https://docs.nopcommerce.com/en/installation-and-upgrading/technology-and-system-requirements.html
If you have setup the server then you probably need to check for errors in the logs
See https://www.selectsystems.com.au/checking-for-errors-on-a-new-installation-of-nopcommerce
один месяц назад
Thanks Yidna,
Yes all conditions met.

I removed the files and reinstalled them, but still get the 500 error.

Michael
один месяц назад
I am still unable to run the site. All I am seeing is the directory listing instead of the site itself.
один месяц назад
Hi All,
So, Ive given IIS_IUSRS full access to the root directory. Dangerous I know, but I can figure out why im getting issues on every installation of nopCommece v4.3 (i.e. 500 Internal Server Error).

I've almost given up, but I know this is a great system.

My environment is Azure VM, Windows Server 20012 R2, Plesk and WHMCS. .Net Core 3.1 is installed. I've also enable stdOut Log but nothing has been generated as yet.

This from the event logs:

System
  - Provider
   [ Name]  IIS AspNetCore Module V2
  - EventID 1033
   [ Qualifiers]  0
   Level 4
   Task 0
   Keywords 0x80000000000000
  - TimeCreated
   [ SystemTime]  2020-10-29T10:55:54.000000000Z
   EventRecordID 2355775
   Channel Application
   Computer rh-whserv-003
   Security

- EventData

   Application 'MACHINE/WEBROOT/APPHOST/WAPANELVANSTATETITLES.COM.AU/STORE' has shutdown.
   Process Id: 5200.
   File Version: 13.1.20074.3. Description: IIS ASP.NET Core Module V2 Request Handler. Commit: e81033e094d4663ffd227bb4aed30b76b0631e6d


Can anyone shed any light please?

Michael
один месяц назад
Well, I got one of the sites to work.

Ran this on the power shell command line for the server:
plesk bin server_pref --update-web-app-firewall -waf-rule-engine off

Seems to have done the trick with one installation. Still working on the other.

Michael
один месяц назад
mnc12004 wrote:
Well, I got one of the sites to work.


Why use Windows 2012R2 when its going to end of life soon? Easier just to create a VM with the minimum of win2016 server or above. Just a suggestion. You're doing a lot of work for a depreciating OS version.