Enable SSL locked out of Nop Admin

1 年 前
Apparently, I've done this before and I have no idea how to correct the issues from the control panel. While configuring Nop I enabled SSL certificate, which is a shared certificate and not on the server. Bad mistake. The result is I am locked out of the admin panel. When I try to log in I'm told there are too many redirects and to clear cookies. I know I made the mistake but my only option, that I can see, is to correct it from the control panel.What file or where, I don't know. I've searched but can't figure it out.
Yes, I've tried the clear cookies and dozens of other things. It doesn't get Admin panel access back. Help.
1 年 前
Hello,

The only way to disable SSL if you've enabled it and have been locked out of your administration is to edit the dbo.Stores table in your database and manually disable it from there.

Just edit your dbo.Stores table and set the SslEnabled row of your store to "False". Then just restart your nopCommerce application and you should be able to access your administration again.

Hope that helps!

Regards,
Anton
1 年 前
Hi,
Thanks. I tried that and I got a connection reset error. I've sort of given up on the site. It's frustrating because I loaded product to it and it was mostly configured. Nothing seems to work. Thanks anyway. J
6 个月 前
I am facing same issue. How to enable SSL for store and admin area ? (nopCommerce V 4.30)
6 个月 前
To Enable, follow the steps in the link

https://www.nop-templates.com/how-to-enable-ssl-for-your-nopcommerce-store
2 个月 前
In my case my site worked well locally until I changed Nop.Web properties| Debug: Enable SSL
The next time I ran the solution I was asked to accept the authentication from localhost so I accepted.
Then I could no longer move past the home page without getting too many redirects errors.
Unchecking "enable SSL" checkbox did not work as I no longer am able to run the store in http.
I suppose I could have tried to change the port number, didn't get to that. But what I did was edit the table Store which had 1 record. I changed the Url from "http://localhost:15536/", the url mentioned in Nop.Web debug tab, to "https://localhost:44314/", the SSL url. I also changed SslEnabled from 0 to 1.

I no longer get the redirects and all is in https://localhost:44314 on my local machine
2 个月 前
robertfarquharson wrote:
In my case my site worked well locally until I changed Nop.Web properties| Debug: Enable SSL
The next time I ran the solution I was asked to accept the authentication from localhost so I accepted.
Then I could no longer move past the home page without getting too many redirects errors.
Unchecking "enable SSL" checkbox did not work as I no longer am able to run the store in http.
I suppose I could have tried to change the port number, didn't get to that. But what I did was edit the table Store which had 1 record. I changed the Url from "http://localhost:15536/", the url mentioned in Nop.Web debug tab, to "https://localhost:44314/", the SSL url. I also changed SslEnabled from 0 to 1.

I no longer get the redirects and all is in https://localhost:44314 on my local machine

What Launch setting are you using in your setup?
1 个月 前
Sorry glhays, just saw your question now. By launch setting there are many:
launch in browser, development environment, IIS Express bitness default, hosting mode default (in process), enabled SSL, enabled anonymous authentication, not windows authentication.
Does this answer your question?
3 周 前
robertfarquharson wrote:
In my case my site worked well locally until I changed Nop.Web properties| Debug: Enable SSL
The next time I ran the solution I was asked to accept the authentication from localhost so I accepted.
Then I could no longer move past the home page without getting too many redirects errors.
Unchecking "enable SSL" checkbox did not work as I no longer am able to run the store in http.
I suppose I could have tried to change the port number, didn't get to that. But what I did was edit the table Store which had 1 record. I changed the Url from "http://localhost:15536/", the url mentioned in Nop.Web debug tab, to "https://localhost:44314/", the SSL url. I also changed SslEnabled from 0 to 1.

I no longer get the redirects and all is in https://localhost:44314 on my local machine


I had exactly this.
But I can't seem to fix this issue on a deployed website.
It keeps giving me redirects.
I'm not sure what the URL that I should change it to should be. I just made it https:websitething.domain. Maybe there's another link I have to use.