Problem with SSL

1 anno tempo fa
Hi EveryOne, guys i have a enviroment with SSL but im on checkout in the first step (Billing address ) i confirmed i get the back page (my cart), i saw on the console and get this error

Mixed Content: The page at 'https://my-web/onepagecheckout#opc-billing' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://my-web/checkout/OpcSaveBilling/'. This request has been blocked; the content must be served over HTTPS.

i went to admin to configure my store with ssl but if i active this option i have many direccion on the checkout.
i using nopcommerce 4.30
anyone can help me ?
1 anno tempo fa
In your store settings do you have address set to "https://my-web/checkout/OpcSaveBilling" or
http://my-web/checkout/OpcSaveBilling?
1 anno tempo fa
Set to "https://my-web/checkout/OpcSaveBilling". And when I enable SSL for the store, I can not access the admin area and other pages of the site, such as the login page

SSL settings performed on the server
1 anno tempo fa
http vs https may be cached in your browser;  clear the browser cache.
E.g. Chrome: If your browser is at your store URL, hold down Ctrl and press F5, to refresh page.
1 anno tempo fa
I deleted the browser cache and cookies several times, but it still did not work
1 anno tempo fa
The above about Stores settings is not right; it should not be your checkout URL, just the root - eg.

https://yourdomain.com/

(Include the "/" at the end)

Also, try another browser.
1 anno tempo fa
By changing the code
var storeLocation = webHelper.GetStoreLocation ();  
To
 var storeLocation = webHelper.GetStoreLocation (true); 

Fixed issue with OnePageCheckout page. But I'm looking for a basic solution to the problem
1 anno tempo fa
asadi.bs24 wrote:
Set to "https://my-web/checkout/OpcSaveBilling". And when I enable SSL for the store, I can not access the admin area and other pages of the site, such as the login page

SSL settings performed on the server

Yes this is very confusing.
Can you reach your root domain via https? if so it is working.
It seems you have altered the code in checkout processes as to your comment (true) now it works.
Have you altered other coding?
What does looking for basic solution mean?
As to what NY stated your store setting url is the root address not a route address to a controller of sorts. I assumed that was a given.
7 mesi tempo fa
asadi.bs24 wrote:
Set to "https://my-web/checkout/OpcSaveBilling". And when I enable SSL for the store, I can not access the admin area and other pages of the site, such as the login page

SSL settings performed on the server


I solved it in the following way:
in appSettings.json change
"UseHttpXForwardedProto": true,
to
"UseHttpXForwardedProto": false,
6 mesi tempo fa
Dr.Night wrote:
Set to "https://my-web/checkout/OpcSaveBilling". And when I enable SSL for the store, I can not access the admin area and other pages of the site, such as the login page

SSL settings performed on the server

I solved it in the following way:
in appSettings.json change
"UseHttpXForwardedProto": true,
to
"UseHttpXForwardedProto": false,


if you change store url to https and enable ssl of you project. that might also work