Docker Upgrade - Installation Page

1 mese tempo fa
I have nopCommerce installed in Azure Web App for Containers. I have the App_Data path mounted which contains the appropriate appSettings.json.

I tried updating from 4.50.1 to 4.50.2 this morning, and now I'm stuck with the installation screen.

Can anyone point me to what it's checking before forwarding me to the Installation page? On 4.50.1 I had restarted my container multiple times and it had no issue reading from the mount path before.

I tried re-assigning the mounted paths as well to see if it was a bug there, but no dice.
1 mese tempo fa
For what it's worth - I dropped the version back to 4.50.1 and I got my Store page again.

Is this a bug with 4.50.2 ? Anyone else replicate?
1 mese tempo fa
Not seeing anything directly related in commits. Will need to do more testing.

https://github.com/nopSolutions/nopCommerce/compare/release-4.50.1...release-4.50.2

Does nopCommerce check for simply the presence of App_Data/appsettings.json in order to determine showing Installation page?
1 mese tempo fa
I reproduced the same error by updating to version 4.50.2. The App_Data/appsettings.json file is present. After the downgrade to version 4.50.1 everything is back to working.

I have an error I think related: by installing version 4.50.2 from scratch I can't see any files inside the docker volume folder (but the website is working).

This is the relevant part of my docker-compose file that worked:

    nop:
        image: nopcommerceteam/nopcommerce:4.50.2
        container_name: nop
        restart: always
        volumes:
            - appdata:/app
        networks:
            - internal
            - web    
        ports:
            - "5000:80"              
        depends_on:
            - db  


Maybe something have changed permission-wise with the new version?
1 mese tempo fa
I just inspected the image layers of the tag latest (the same as 4.50 and 4.50.2)https://hub.docker.com/layers/nopcommerce/nopcommerceteam/nopcommerce/latest/images/sha256-9b119f027693c4ad50620f8769c08d685d7a993e039bd21027ac99a800c42293?context=explore

and the tag 4.50.1
https://hub.docker.com/layers/nopcommerce/nopcommerceteam/nopcommerce/4.50.1/images/sha256-d13e0631d9748f567a64ea6a57a29c1e37cfac8b7c62e99fd70b0a48d9449e65?context=explore

there are some missing lines after the 14th layer, the error is probably the missing WORKDIR /app
1 mese tempo fa
Was this Dockerfile used during the push of the 4.50.2 image - even though it has a GitHub diff of only 6 days ago?

https://github.com/nopSolutions/nopCommerce/commit/8472d55251c2f679ff15e4baf5ecb574032f8337#diff-dd2c0eb6ea5cfc6c4bd4eac30934e2d5746747af48fef6da689e85b752f39557L81
1 mese tempo fa
We updated the image on the dockerhub and returned the file system structure in accordance with previous versions. For more details please see the PR from Mitch Barry.
1 mese tempo fa
Thanks, I was able to update to the newly deployed 4.50.2 image without issue!