ERR_TOO_MANY_REDIRECTS

3 年 前
As you can see the error message has changed from ERR_TOO_MANY_REDIRECTS to INET_E_REDIRECT_FAILED
I guess this has changed after an reload/reset on IIS.

I changed sslEnable from True to False in the database (shouldn't do changes like this, but I had to get the store up and running) - and then the store shows up.

Is it something wrong with the certificate that makes this happen, or is it something with the infrastructure?
Load balancing, etc...?
3 年 前
hi jklevela
im having similairt issues after enabling ssl on my version 3.9 site
can you tell me how you disabled sslEnable from True to False in the database ?
Thanks !
3 年 前
select * from [DB].dbo.Setting s where s.name = 'securitysettings.forcesslforallpages'
2 年 前
The above post worked for me.

Under Settings -> General, you can scroll down to the Security tab and find the 'Force SSL for all site pages'.  I set this to true, restarted the site, and the error disappeared.
11 个月 前
jklevela wrote:
Just added https://yourstore.com in the field for Secure URL. (but replaced with my url of course)


where is the secure URL field in nop 4.20 ???
11 个月 前
Secured Url not required in 4.2. It’s removed.
11 个月 前
I am configured as

store URL   http://www.mywebsitename.com/
host values mywebsitename.com,www.mywebsitename.com
SSL enabled    checked

securitysettings.forcesslforallpages    true

please advise, thank you in advance, Rob
11 个月 前
Make store url exactly same as your site url. In this case it should be https://www.mywebsitename.com/
11 个月 前
i have added the "s"
saved
cleared cache
restarted application

the website loads, i can go to a category page, then a product page, add a product to cart.  then when i go to the shopping cart page the error occurs
11 个月 前
What is the error there?