Cannot Get nopcommerce 4.1 to run in Azure as PaaS.

Posted: August 12, 2019 at 11:29 AM Quote #243602
Version:  nopcommerce 4.1
platform Azure, platform as a service using Azure app-services.

I have been trying to get a copy of our nopcommerce site running in azure... for over a month.  We are doing platform as a service.  It's literally been one thing after another, and I just cannot seem to get this to work.

All the instructions I see for running nop in the cloud on azure are either for Hardware As A Service or are really, REALLY old.

Are there any instructions for running nopcmmerce 4.1 in Azure?  If anyone has any links or instructions, that would be really, really awesome.

At the moment all I get is the infuriating"

"The specified CGI application encountered an error and the server terminated the process."

generic error message.

I tried looking at the eventlog.xml in azure, but there is basically nothing there in the way of an error message.  I tried turning on the stdout logging, but no log files are generated.

I also tried launching the site from the azure console, but all I get is this:

"Application: dotnet.exe CoreCLR Version: 4.6.27817.1 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.IOException: Failed to bind to address http://127.0.0.1:5000: address already in use."

Any help in-site, information would be greatly appreciated.  Thanks.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
- Aaron
IT Team Lead
eStore
Posted: August 14, 2019 at 12:29 AM Quote #244652
ahall wrote:
Version:  nopcommerce 4.1
platform Azure, platform as a service using Azure app-services.

I have been trying to get a copy of our nopcommerce site running in azure... for over a month.  We are doing platform as a service.  It's literally been one thing after another, and I just cannot seem to get this to work.

All the instructions I see for running nop in the cloud on azure are either for Hardware As A Service or are really, REALLY old.

Are there any instructions for running nopcmmerce 4.1 in Azure?  If anyone has any links or instructions, that would be really, really awesome.

At the moment all I get is the infuriating"

"The specified CGI application encountered an error and the server terminated the process."

generic error message.

I tried looking at the eventlog.xml in azure, but there is basically nothing there in the way of an error message.  I tried turning on the stdout logging, but no log files are generated.

I also tried launching the site from the azure console, but all I get is this:

"Application: dotnet.exe CoreCLR Version: 4.6.27817.1 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.IOException: Failed to bind to address http://127.0.0.1:5000: address already in use."

Any help in-site, information would be greatly appreciated.  Thanks.




You have to provide full write permission to log folder to generate log files.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Pls up-vote the answer, if it helps you!

Thank's,
Sangeet Shah
====================================================
NopAdvance - nopCommerce Solution Partner
Website: https://nopadvance.com
Posted: August 14, 2019 at 12:30 AM Quote #244653
ahall wrote:
Version:  nopcommerce 4.1
platform Azure, platform as a service using Azure app-services.

I have been trying to get a copy of our nopcommerce site running in azure... for over a month.  We are doing platform as a service.  It's literally been one thing after another, and I just cannot seem to get this to work.

All the instructions I see for running nop in the cloud on azure are either for Hardware As A Service or are really, REALLY old.

Are there any instructions for running nopcmmerce 4.1 in Azure?  If anyone has any links or instructions, that would be really, really awesome.

At the moment all I get is the infuriating"

"The specified CGI application encountered an error and the server terminated the process."

generic error message.

I tried looking at the eventlog.xml in azure, but there is basically nothing there in the way of an error message.  I tried turning on the stdout logging, but no log files are generated.

I also tried launching the site from the azure console, but all I get is this:

"Application: dotnet.exe CoreCLR Version: 4.6.27817.1 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.IOException: Failed to bind to address http://127.0.0.1:5000: address already in use."

Any help in-site, information would be greatly appreciated.  Thanks.


can you please generate ticket on your hosting provide? i think they help you better in this case.
This post/answer is useful
0
This post/answer is not useful

Please login or register
to vote for this post.

(click on this box to dismiss)
Pls up-vote the answer, if it helps you!

Thank's,
Sangeet Shah
====================================================
NopAdvance - nopCommerce Solution Partner
Website: https://nopadvance.com
Premium support services
  • Dedicated premium support services provided by core developers are intended for persons who run mission critical websites, work on projects with tight deadlines, or want to get dedicated support.
Professional services
  • Want to open a new store? Want to take your store to the next level? Need a custom extension? We can customize nopCommerce to fit your store perfectly. Request a quote to get started.
eCommerce CONFERENCE 2019
Learn more