1.4 upgrade script

10 years ago
So I'm trying to do a manual upgrade to 1.4 from 1.3 and have run into some issues with the upgrade script.

IF EXISTS (
    SELECT 1 FROM syscolumns WHERE id=object_id('[dbo].[Nop_ProductVariant]') and NAME='RequiresTextOption')
BEGIN
  ALTER TABLE [dbo].[Nop_ProductVariant]
  DROP COLUMN RequiresTextOption
END
GO

IF EXISTS (
    SELECT 1 FROM syscolumns WHERE id=object_id('[dbo].[Nop_ProductVariant]') and NAME='TextOptionPrompt')
BEGIN
  ALTER TABLE [dbo].[Nop_ProductVariant]
  DROP COLUMN TextOptionPrompt
END
GO

But further up the script these columns are referenced in the Nop_ProductVariantInsert and Nop_ProductVariantUpdate sprocs...

    INSERT
    INTO [Nop_ProductVariant]
    (
     ...
        RequiresTextOption,
     ...

  UPDATE [Nop_ProductVariant]
  SET
                ...
    [email protected],
                ...


WTH??
10 years ago
This seems to be all kinds of sprocs in the upgrade script... how has anyone upgraded successfully??
10 years ago
The SPs "Nop_ProductVariantInsert" and "Nop_ProductVariantUpdate" are redefined at the end of the (1.30 -> 1.40) script "nopCommerce_upgrade.sql" without references to the "RequiresTextOption" and "TextOptionPrompt" fields.

.