Roxy Fileman - blank screen after updating from 3.9 to 4.0

1 year ago
I just completed the process of upgrading from 3.9 to 4.0 earlier this week. Things went smooth and 4.0 is definitely faster.

The only issue we have had is that when modifying content and trying to upload a picture, when we select the button to upload, we get a screen that overlays everything with "Roxy Fileman" at the top and the contents are completely blank.

I know the upload folder is in a different location than before (in wwwroot/images) and everything is there as it was in its prior location at content/images/upload.

Any idea what I'm dealing with?
1 year ago
Any ideas? I'm a bit at a loss - not even sure where to start.
1 year ago
More details - here's the error I'm seeing:

Uncaught ReferenceError: RoxyUtils is not defined
    at HTMLDocument.<anonymous> (VM2724 main.min.js:168)
    at j (VM2721 jquery-1.11.1.min.js:1)
    at Object.fireWith [as resolveWith] (VM2721 jquery-1.11.1.min.js:1)
    at Function.ready (VM2721 jquery-1.11.1.min.js:1)
    at HTMLDocument.J (VM2721 jquery-1.11.1.min.js:1)
(anonymous) @ VM2724 main.min.js:168
j @ VM2721 jquery-1.11.1.min.js:1
fireWith @ VM2721 jquery-1.11.1.min.js:1
ready @ VM2721 jquery-1.11.1.min.js:1
J @ VM2721 jquery-1.11.1.min.js:1


I have a developmental environment that works exactly as expected in both debug and release. I've replaced the lib files for both Roxy_fileman and tinymce with the folders created when I do a Release build. Still seeing the same issue.
1 year ago
I am getting this same error as well. Has there been any resolution to the error?
1 year ago
Did anyone find out how to solve this issue as we have also encountered it
1 year ago
I"m having the same issue, has anyone solved this issue? Please help, I'd appreciate it
8 months ago
I have same issue I am using nopcommerce version 4.0. on azure it working fine now when I click to insert image in html text editor this error come up.

I can see error in console.
3 months ago
I was facing the same issue after I upgraded my site from 3.7 to 4.1

I saw 2 errors in the console

1.Uncaught ReferenceError: RoxyUtils is not defined
2. Uncaught SyntaxError: Invalid or unexpected token in wwwroot/lib/tinymce/plugins/paste/plugin.min.js (not related to this issue)

So I downloaded fresh nop 4.1 (no source) same version as my site from GitHub and re-uploaded the folder:wwwroot/lib/Roxy_Fileman/js, And it resolved the issue

Then (optionally) I re-uploaded wwwroot/lib/tinymce/plugins/paste/plugin.min.js which resolved the second error.

if it still doesn't work or you are facing a similar issue after an upgrade, deleting and re-uploading wwwroot/lib should resolve the issue IMO.