FCK Editor Weirdness

11 years ago
Hi there,

I have just uploaded the NopCommerce to my hosting and everything looked fine.

However i have just noticed that whenever i add a product, neither the textbox or the FCK Editor show for the body.
I can add text to the short description as this is just click and type but the actual 'body' text won't let me click anywhere.
Is this a possible issue with folder permissions or have i not configured something correctly.

Any help would be greatly appreciated.

Kind Regards

John
11 years ago
I think it is to do with the path for the FCK Editor as this isn't showing up anywhere that it should be - topics descriptions etc.
Does anyone out there know where i can configure the FCK editor to work correctly by changing the file path etc?

Regards

john
11 years ago
Please look at this topic
11 years ago
Hi there,

Thank-you for your reply.
I have looked at the post you linked me to which was great - really good to know where to make the amendments.
However, i created the userfiles folder on the root of my site with the images folder inside and performed a CHMOD on the userfiles folder to change the permissions to read, write & execute.
I then performed the amendments to the code and unfortunately i am still no further. it didn't work :(

The browser looks as if it is going to load it right up until the last minute where it stops and says done.

do i need to place anything into these folders?

it say on the post 'add another folder called image.

'this is where the images will be saved'
Which images is it refering to?

Kind Regards

John
11 years ago
John,

May I ask what version of nopCommerce you are running.

First basic things to try is to clear your browser cache and reload your page.

Next thing you can check is that FredCK.FCKeditorV2.dll is present in your sites /bin directory.

Check that:

    <add key="FCKeditor:BasePath" value="~/editors/fckeditor/"/>

Is present inside the appSettings section within web.config.

Make sure on the page you are using FCKeditor that the control is correctly registered (if you havent made any changes it should be):

<%@ Register Assembly="FredCK.FCKeditorV2" Namespace="FredCK.FCKeditorV2" TagPrefix="FCKeditorV2" %>

Hope this helps,
Ben
10 years ago
Hi there Ben.

I am using the latest  release 1.30
I have tried the first method of clearing the cache and this didn't work.
Double checked that the appSettings section of the web.config file were correct - didn't work.
The control is definately correct.

so.......

Not really sure where to go from here......

I have also replaced the FCKEditor folder and also the .DLL but again that didn't work.

I mentioned earlier that i have got it working locally from just a standard install so i tried to change the web.config and the FCK editor config to use /userfiles/ - then created the userfiles and the image folder and this worked but again locally. :(

it is a real pain for me as the rest of my site is working brilliantly but i just cannot edit ANY of my topic pages or product descriptions etc etc - i have to do it live on the database. :(

Do you possibly have any other ideas of how i can either repair or fix this problem.

Would it be too difficult to integrate the latest FCK editor into the framework - think it is version 3?

Any help greatly appreciated
John
10 years ago
also,

when i go to any admin page that uses the editor in internet explorer i get the following error:
    

More information

This problem can be caused by a variety of issues, including:

•Internet connectivity has been lost.
•The website is temporarily unavailable.
•The Domain Name Server (DNS) is not reachable.
•The Domain Name Server (DNS) does not have a listing for the website's domain.
•There might be a typing error in the address.
•If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

This is displayed in the section where the FCKEditor should be next to 'Body'

strange...

john
10 years ago
John,

Have you tried just adding FCKeditor to a new page in order to test?

Is the site live anywhere so I can test (can PM me if you want)?

You say you have managed to get it working locally - is this the same version of the site you have uploaded to your third party servers?

I'm pretty sure that even if there was a problem with permissions on the user files directory the control should still load, it would just fail if you tried to "browse server".

Thanks
Ben
10 years ago
Hi there Ben,

Once again thanks for your assistance with this issue.

I have now tested the same files i have online locally and they work with the FCK Editor (locally but not online).

I have created a new page within the root of my site called test.aspx, added the fck control and also added the ditor to the page and locally 'yes' this does work.

I have then uploaded the test.aspx page to my live server and the page doesn't work with the FCK Editor.

I have checked also that the site is still configured to use 'userfiles' and 'userfiles/image' which it is...... - this is the same configuration as i am running locally.

Just wondered, if i PM you with the site what details would your require to help me? would you need admin access?

Kind Regards
John
10 years ago
Have you responded to Retroviz...

"Is the site live anywhere so I can test (can PM me if you want)?"

??? Yes/No