Version 3.9 is very slow

3 years ago
Hi,

I have recently downloaded the latest version of Nopcommerce, and I uploaded the site to the live server. but all pages are very slow to open. please any help or tip would appreciated.

Regards,
3 years ago
It usually takes several minutes for new installation to "warm up". After that it should run fast.


3 years ago
some suggestions:
1:  check your server resource usage status, like memory & cpu usage.
2:  check the log in admin portal, see if some resource is not available.
3:  select some of free website monitoring software like newrelic.com, uptrend, you can check page performance, basically you will know which part is loading slow.

cheers
3 years ago
Thank you guys for the suggestions, I will try.
3 years ago
Currently I am following these steps in order to build nopcommerce website:

1. Open the solution in Visual Studio
2. Re-build the entire solution
3. Publish the "Nop.Web" project from Visual Studio

P.S. When publishing ensure that configuration is set to "Release"

When I deploy these changes to IIS the application takes about 22 seconds for the first load. And also it takes the same time for subsequent loads,

I got these numbers from google Chrome Performance tab:

Total time: 21839 ms

360.6 ms Loading
1153.0 ms Scripting
866.3 ms Rendering
238.5 ms Painting
414.4 ms Other
18805.8 ms Idle

NopCommerce Demo binaries:
If I use the binaries from nopcommerce web page (download - no source) and I deploy these changes on the same website, with same settings it takes just 4 seconds to load the home page.

I can see the difference in the idle process, but again, I am using the same setting on IIS website for both (demo and my site)
3 years ago
I have noticed that my nopcommerce version is also super slow.
One thing i have noticed if you're running on another language it will generate a warning that it's missing all kind of string resources. When that warning is generated it will insert a record in Log table in DB. So for example when i was searching for a product there was over 100 records inserted in my log table because it were missing several string resources.

My quick soulition for this was to copy all the English string resources and insert it with all the other languages. After that it was running much faster.
2 years ago
I think that Nop is very good, if not excelent product.

I noticed that some parts of this product is set on purpose to be bad,  or even unusable for profesional use, e.g. performance issue...

Regardless that there are some very simple and cheap solutions, they are never in basic installation. You must buy that specific knowledge/plugin in order to resell your product based on Nop.

Recently, I thought that is impossible to run Nop under 1 sec with 10.000 products on shared server. If you want to have such performancw, apparently you must pay for that upgrade ...

So, Nop is open source software, but it is not free :-) and I support that.
2 years ago
All big systems require warmup. It's the same for EpiServer and their likes.

That is why you need a service that continously polls the system. There already is one in place in fact, best to use it :).
2 years ago
robinrogne wrote:
I have noticed that my nopcommerce version is also super slow.
One thing i have noticed if you're running on another language it will generate a warning that it's missing all kind of string resources. When that warning is generated it will insert a record in Log table in DB. So for example when i was searching for a product there was over 100 records inserted in my log table because it were missing several string resources.

My quick soulition for this was to copy all the English string resources and insert it with all the other languages. After that it was running much faster.


Yes same problem with swedish language i try to same as the above... thank you



1 Exported english lang pack
2 Imported the english file to the swedish
3 Imported back the swedish lang pack

Works fine, now its fast..