No Database Instance in nopcommerce 3.90

4 years ago
I am facing error in nopcommerce 3.90 when run the project at that also at sometimes it is working good but after sometimes it shows the error of "no database instance". I am surprised that why it shows this type of error. Because the normal thing I have done to run the nopcommerce project. like

set the setting file by installation of nopcommerce.

delete the bin folder of nopcommerce.

clean the solution and rebuild it.

But still facing the same issues.

even there is many question related to this error, I review also but no such solution is get.

Please help me to solve this issues.

Thank You.
4 years ago
Hello,

You created one question here: https://www.nopcommerce.com/boards/t/48267/no-database-instance-in-nopcommerce-390.aspx

Then why create same question again? Its make as duplicate.

We have to make this forum as best forum. So please try to reduce duplication of questions.

Thanks,
Jatin
4 years ago
sorry for that.

So do you know the solution of this question?
4 years ago
if u run on local machine some times the sql stops
open sqlServerManager.msc (should be somewhere in your windows/system32 folder)
u can start the sql server from there
2 years ago
There are some of summery solution that i have mention as below
=> Since i had moved a live cart to a test server, the settings in the database for that cart had force ssl and also force www before any url. Also under Store settings i still had the domain info for that site which was now difrent in the test server. Once i noticed this and updated the database it all started working.

=>  You try change settings.txt file:
DataConnectionString: Data Source=localhost/IP;Initial Catalog=DBName;Integrated Security=False;Persist Security Info=False;User ID=DBUser;Password=DBPass;MultipleActiveResultSets=True

=> In my case I need config application pool for nopcomerce

my connection string
DataProvider: sqlserver
DataConnectionString: Data Source=.;Initial Catalog=nopcommerce370;Integrated Security=True;Persist Security Info=False

I need set Application Pool Identity to user has access right to db
Check the image to details.

=>  Check also db permission.

=> try with
Data Source=9X.2XX.7X.XX\"yoursqlservenameinstance"
or
Data Source="yournamemachine"
or
Data Source="yournamemachine"\"yoursqlservenameinstance"